Closed Bug 334970 Opened 14 years ago Closed 14 years ago

Combobox keeps growing in this case when zooming in and then zooming out

Categories

(Core :: Layout, defect)

x86
Windows XP
defect
Not set
normal

Tracking

()

VERIFIED FIXED

People

(Reporter: martijn.martijn, Assigned: dbaron)

References

()

Details

(Keywords: regression, testcase, Whiteboard: [reflow-refactor])

Attachments

(1 file)

See upcoming testcase

When doing trl+ multiple times and then ctrl- multiple times, the select drop down is growing in width, which shouldn't happen.

This regressed between 2004-05-31 and 2004-06-01:
http://bonsai.mozilla.org/cvsquery.cgi?treeid=default&module=all&branch=HEAD&branchtype=match&dir=&file=&filetype=match&who=&whotype=match&sortby=Date&hours=2&date=explicit&mindate=2004-05-31+10&maxdate=2004-06-01+09&cvsroot=%2Fcvsroot

The only possible cause for this regression seems to me bug 217527.
Attached file testcase
Whiteboard: [reflow-refactor]
-> dbaron per regression analysis
Assignee: nobody → dbaron
Flags: blocking1.9a1?
Flags: blocking1.9a1? → blocking1.9-
Whiteboard: [reflow-refactor] → [reflow-refactor][wanted-1.9]
This is fixed on the reflow branch.  Note to self -- when zooming, the <select> is expected to not get wider, since the table has a fixed width and the <select> has a percentage width.
Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.9a1) Gecko/20061208 Minefield/3.0a1 ID:2006120812 [cairo]

confirmed fixed on trunk now that reflow branch has landed
Status: NEW → RESOLVED
Closed: 14 years ago
Resolution: --- → FIXED
Verified with the 2006-12-08 build.
Status: RESOLVED → VERIFIED
Depends on: reflow-refactor
Adding in-testsuite? nomination per bz's request in m.d.t.l. Sorry for the bugspam.
Flags: in-testsuite?
Flags: wanted1.9+
Whiteboard: [reflow-refactor][wanted-1.9] → [reflow-refactor]
Flags: in-testsuite?
Flags: blocking1.9-
You need to log in before you can comment on or make changes to this bug.