Month view multiplies events

RESOLVED FIXED

Status

Calendar
Sunbird Only
RESOLVED FIXED
12 years ago
12 years ago

People

(Reporter: Michiel van Leeuwen (email: mvl+moz@), Assigned: Joey Minta)

Tracking

Details

Attachments

(2 attachments, 1 obsolete attachment)

22.29 KB, image/png
Details
1.94 KB, patch
Michiel van Leeuwen (email: mvl+moz@)
: first-review+
Details | Diff | Splinter Review
When (forward) browsing the month views, a weekly recurring event gets displayed many times. Event-boxes for the new month get added, but the old boxes are not removed.
Steps to reproduce:
- Switch to month view
- Create a weekly recurring event, no end date
- Browse to the next month
- Observer that the event is displayed twice, once for the currently displayed month, and once for the previous month (as the tooltip tells us)

This makes using the month view with recurring events pretty hard, so marking as blocker.

(If we can't find a solution, we could turn of the re-use of the grid. That would be a performance hit, but solve this problem)
(Reporter)

Comment 1

12 years ago
Actually, all kinds of events stay on the view, not just recurring events. Sometimes the boxes are removed, but most are not. I can't tell what determines if a box is removed or not.
Summary: Month view multiplies recurring events → Month view multiplies events

Comment 2

12 years ago
Created attachment 219373 [details]
multiweek screenshot

Event and day boxes in multiweek view are affected too. Also the box style gets screwed up. (See attached screenshot.)

It works in the 2006-04-19-07 build and fails in the 2006-04-20-07 build. Bug 334704 was the only check in to mozilla/calendar during that time.

Comment 3

12 years ago
Created attachment 219377 [details] [diff] [review]
patch

This patch fixes Bug 334996 and Bug 334724. 
Therefore the patch on Bug 334724 is obsolete.

We should check if the change to calIDuration did not regressed other places.
Attachment #219377 - Flags: first-review?(dmose)

Comment 4

12 years ago
Comment on attachment 219377 [details] [diff] [review]
patch

The patch fixes the problem but is wrong. With this patch we always hit the "shouldn't ever happen" case in relayout(). So we need another solution.
Attachment #219377 - Attachment is obsolete: true
Attachment #219377 - Flags: first-review?(dmose)
(Assignee)

Comment 5

12 years ago
Created attachment 219442 [details] [diff] [review]
fix proper while

The while loop to remove the old events was never getting called.  Ignore the newDuration bit, since that's fixed in another bug.
Assignee: nobody → jminta
Status: NEW → ASSIGNED
Attachment #219442 - Flags: first-review?(mvl)
(Reporter)

Comment 6

12 years ago
Comment on attachment 219442 [details] [diff] [review]
fix proper while

looks right, r=mvl

But now we hit the next problem:
[JavaScript Error: "box.date has no properties" {file: "chrome://calendar/content/calendar-month-view.xml" line: 1097}]
(while browsing). I really start to wonder if we should remove the re-use of the grid.
Attachment #219442 - Flags: first-review?(mvl) → first-review+
(Reporter)

Comment 7

12 years ago
Patch checked in.
(the error i saw was bogus, a bug in my setup)
Status: ASSIGNED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.