Closed Bug 335044 Opened 14 years ago Closed 11 years ago

cmd+w doesn't close About window and Preferences window on OS X

Categories

(Thunderbird :: General, defect, P3)

PowerPC
macOS
defect

Tracking

(Not tracked)

RESOLVED FIXED
Thunderbird 3.0b2

People

(Reporter: Usul, Assigned: philor)

References

Details

Attachments

(1 file)

Step to reproduce :
1) in Thunderbird menu choose About
2) try to close the window with cmd-w (normal mac shortcut to close windows).

results : window doesn't close

expected results : window should close.

using version 1.5.0.2 (20060308)

This is mac specific. I have enigmail installed.
also on windows trunk, ctrl+w
(In reply to comment #1)
> also on windows trunk, ctrl+w
> 

Same problem exists for the Settings window (Mac) and Options window (Windows). Probably not worth opening a new bug for that, though, as the fix is likely the same. Tested with the 3.x build.
(In reply to comment #2)
> (In reply to comment #1)
> > also on windows trunk, ctrl+w
> > 
> 
> Same problem exists for the Settings window (Mac) and Options window (Windows).
> Probably not worth opening a new bug for that, though, as the fix is likely the
> same. Tested with the 3.x build.
> 


Oh, Command-W also does not work in the "Message Filters" window on the Mac (though Control-W works in Windows for this one)
Phil,  This appears to be true of other modal windows. For example new AB card and account settings.
Working as designed, ie. INVALID?
Severity: minor → trivial
OS: Mac OS X → All
Hardware: Macintosh → All
Summary: Close shortcut doesn't work on About window → Close shortcut doesn't work on About window and other modal windows - cmd-w, ctrl+w
Duplicate of this bug: 379659
No, not working as designed, and not all-all. Simple steps to see what should happen: open Safari, About Safari, cmd+w, Preferences, cmd+w, then open IE/Win, About Internet Explorer, ctrl+w, (Esc so it actually closes), Internet Options, ctrl+w, (Esc so it actually closes).
Assignee: mscott → philringnalda
Severity: trivial → normal
OS: All → Mac OS X
Hardware: All → Macintosh
Summary: Close shortcut doesn't work on About window and other modal windows - cmd-w, ctrl+w → Close shortcut doesn't work on About window and other modal windows - cmd-w
Version: 1.5 → Trunk
In fact, surprisingly enough, the total alien Safari/Win doesn't close About or Prefs with ctrl+w.
Priority: -- → P3
Target Milestone: --- → Thunderbird 3
Duplicate of this bug: 355628
Flags: wanted-thunderbird3?
Attached patch Fix v.1Splinter Review
Doesn't seem likely that I'll be porting bug 239218 any time soon, so this ports back the addition bug 222364 made when it ported our bug 271855.

I did consider fixing it the way the filters dialog is fixed, by just using utilityOverlay to avoid a new string and making accel+w close them on all platforms, but comment 6 is still true, and closing about/prefs on Windows or Linux with ctrl+w is non-native.
Attachment #349627 - Flags: review?(bugzilla)
Flags: wanted-thunderbird3? → wanted-thunderbird3+
Summary: Close shortcut doesn't work on About window and other modal windows - cmd-w → cmd+w doesn't close About window and Preferences window on OS X
Target Milestone: Thunderbird 3 → Thunderbird 3.0b2
Attachment #349627 - Flags: review?(bugzilla) → review+
http://hg.mozilla.org/comm-central/rev/58742e5d95b2
Status: NEW → RESOLVED
Closed: 11 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.