Closed Bug 335060 Opened 14 years ago Closed 14 years ago

script timeout too small in firefox

Categories

(Firefox :: General, enhancement)

x86
Windows XP
enhancement
Not set

Tracking

()

RESOLVED DUPLICATE of bug 335058

People

(Reporter: ratan.work, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.2) Gecko/20060409 Firefox/1.5.0.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.2) Gecko/20060409 Firefox/1.5.0.2

We have been seeing "Warning: Unresponsive Script" dialog box a lot in yahoo mail beta and it happens a lot when some cpu intensive application is running on users box and they tries to check mail.

The value of dom.max_script_run_time in FF 1.5.0.2 is 5 second. It seems to be too low compare to what IE offers. Even though user can change it in about:config but it is too hard to tell millions of users to do so.

To compare it with IE:
IE timesout after executing 5,000,000 statements on current page.
http://support.microsoft.com/?kbid=175500

Wouldn't it be a good idea to set dom.max_script_run_time to 60 sec or
something like that in FF by default (I mean something reasonably high)? The
value of 5 sec seems to be too low.

Some of the bugs already filed on it are:
https://bugzilla.mozilla.org/show_bug.cgi?id=250841
https://bugzilla.mozilla.org/show_bug.cgi?id=330293
https://bugzilla.mozilla.org/show_bug.cgi?id=308205
https://bugzilla.mozilla.org/show_bug.cgi?id=320409
https://bugzilla.mozilla.org/show_bug.cgi?id=320020
https://bugzilla.mozilla.org/show_bug.cgi?id=320409



Reproducible: Sometimes

*** This bug has been marked as a duplicate of 335058 ***
Status: UNCONFIRMED → RESOLVED
Closed: 14 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.