Deleting account removes too many accounts from prefs.js

RESOLVED DUPLICATE of bug 273311

Status

--
critical
RESOLVED DUPLICATE of bug 273311
13 years ago
13 years ago

People

(Reporter: mlueck, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.12) Gecko/20050915
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.7.12) Gecko/20050915

Through the GUI interface, I selected an account I no longer needed and deleted it. Just that account was removed from the mail/news interface. But upon restarting Mozilla, several accounts are gone. I thought there was some sort of linkage associating the NNTP accounts with the Mail account I removed, but I finally tracked it down to the bug described below...

I am flagging it via "loose data" as for folks that do not get in and work with the profile files line by line, they would have no clue how to recover from this.

Reproducible: Always

Steps to Reproduce:
1. Through the GUI interface, I selected an account I no longer needed and deleted it.
2. Just that account was removed from the mail/news interface.
3. Close and restart Mozilla, several accounts are gone.


Actual Results:  
Multiple accounts (name match 1* vs just 1) are removed from prefs.js

Expected Results:  
Just the one account would be removed.

The code which removes these entries from prefs.js has a bug...

user_pref("mail.account.account1.identities", "id1");
user_pref("mail.account.account1.server", "server1");

It deletes account1* vs just account1

The code needs to be updated to verify that the next char is the period, not simply name match that "we have account1 so delete it" and thus zap 10, 11, 12, 13, 14, etc...

Comment 1

13 years ago
Fixed in SeaMonkey 1.0 or higher.

*** This bug has been marked as a duplicate of 273311 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.