content type text/troff should be displayed as text (by http)

RESOLVED WORKSFORME

Status

()

--
enhancement
RESOLVED WORKSFORME
13 years ago
3 years ago

People

(Reporter: vincent-moz, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.2) Gecko/20060308 Firefox/1.5.0.2
Build Identifier: Mozilla/5.0 (Macintosh; U; PPC Mac OS X Mach-O; en-US; rv:1.8.0.2) Gecko/20060308 Firefox/1.5.0.2

When I want to open a text/troff file by http, Firefox displays a meaningless message, e.g. "You have chosen to open efing.1 which is a: 1 file". 1 is not a file format, but a manual section.

Reproducible: Always

Steps to Reproduce:
1. Open http://www.vinc17.org/unix/efing.1
Actual Results:  
Firefox says:
  You have chosen to open efing.1 which is a: 1 file

Expected Results:  
Firefox should have said:
  You have chosen to open efing.1 which is a: troff file
(or possibly give the complete MIME type text/troff).

With "file:" instead of "http:", the troff file is opened in Firefox as a text/plain file, so that there is no meaningless message in this case.

Comment 1

13 years ago
See also bug 335171.

Comment 2

4 years ago
This may be a dupe of bug 57342
Severity: normal → enhancement
Status: UNCONFIRMED → NEW
Component: Networking → Networking: HTTP
Ever confirmed: true
OS: Mac OS X → All
Hardware: PowerPC → All
Summary: meaningless message when trying to open text/troff files (by http) → content type text/troff should be displayed as text (by http)
(Reporter)

Comment 3

4 years ago
(In reply to Frankie from comment #2)
> This may be a dupe of bug 57342

No (though fixing bug 57342 would fix this bug as a consequence), the problem I had reported was about a meaningless message "You have chosen to open efing.1 which is a: 1 file". Re-read the bug report. However I can no longer reproduce this problem (but now I'm under Linux, in case this was specific to Mac OS X): now Firefox 35.0 says "Troff document" instead of "1 file". This is correct.
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.