View Stored Passwords dialog broken

VERIFIED FIXED

Status

SeaMonkey
Passwords & Permissions
P3
blocker
VERIFIED FIXED
18 years ago
13 years ago

People

(Reporter: sairuh (rarely reading bugmail), Assigned: Stephen P. Morse)

Tracking

({pp, regression})

Trunk
pp, regression

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

18 years ago
found while using the following:

linux, opt comm: 2000.03.27.11
macOS, opt comm: 2000.03.27.10
winNT, opt comm: 2000.03.27.09

to repro:
1. start browser.
2. go to Tasks > Personal Manangers > Password Manager > View Stored Passwords
OR open Preferences > Forms and Passwords > View Stored Passwords.

result: a blank dialog window appears. the only difference btwn access from menu
and access from Prefs is that the dialog that appears via Prefs is maximized.

expected: Password Viewer dialog should display its content.

this is what i see in the console (taken while using linux build):

XML Error in file 'chrome://wallet/content/SignonViewer.xul', Line Number: 75,
Col Number: 31, Description: undefined entity
Source Line:                         value="&removeall.label;"
(Reporter)

Updated

18 years ago
Keywords: regression
(Reporter)

Updated

18 years ago
Blocks: 32882
(Reporter)

Updated

18 years ago
Blocks: 29839
(Assignee)

Comment 1

18 years ago
Fix checked in.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED
(Reporter)

Comment 2

18 years ago
was able to verify as fixed on winNT and linux [opt comm, 2000.03.29.09], using
an existing profile. however, on macOS the View Signons dialog would *not*
appear when i used an existing profile. (it did work when i used a fresh
profile.) am i running into another [existing?] bug here?
(Reporter)

Comment 3

18 years ago
after chatting w/steve, i copied the mac profile in question to my winNT to see
what would happen: still unable to open the View Signons dialog, even using
today's opt comm bits on winNT. will attach the zip'd up profile soon...
Status: RESOLVED → REOPENED
Keywords: pp
OS: All → Mac System 9.0
Hardware: All → Macintosh
Resolution: FIXED → ---
Summary: View Stored Passwords dialog borken → View Stored Passwords dialog broken (existing profile)
(Reporter)

Comment 4

18 years ago
Created attachment 7070 [details]
zip archive of existing mac profile
(Assignee)

Comment 5

18 years ago
Using your zipped up profile, I had no trouble opening the signon viewer on my 
NT browser.
(Reporter)

Comment 6

18 years ago
even though i've only seen this problem on the mac (so far), i wonder if this
particular bug might be in any way related to bug 33613. i see similar problems
trying save signons with an existing profile, ie, the same profile in which i
see this bug.
Bug 33613 is now resolved; see it for my explanation of what I think happened.

Gerv
(Reporter)

Updated

18 years ago
No longer blocks: 32882
(Reporter)

Updated

18 years ago
No longer blocks: 29839
(Assignee)

Comment 8

18 years ago
Closing this out as fixed since the original problem had indeed been fixed 
(there was an entry missing for "removeall.label" in the commercial tree only).

The bug was then morphed and reopened as a problem having to do with old 
profiles.  This should have been a new bug report.  If that is still a problem, 
then open a new bug on it.  But as I was unable to reproduce that problem, and 
as it had to do with an old profile only, I don't think we have to worry about 
it reoccuring.
Status: REOPENED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → FIXED
(Reporter)

Comment 9

18 years ago
hokay. i'll file another bug about this not working for an existing profile on
Mac, and verify this one with its original summary.
Status: RESOLVED → VERIFIED
OS: Mac System 9.0 → All
Hardware: Macintosh → All
Summary: View Stored Passwords dialog broken (existing profile) → View Stored Passwords dialog broken
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.