hitting return in dialog passes through to location bar

VERIFIED DUPLICATE of bug 29165

Status

()

Core
XUL
P4
normal
VERIFIED DUPLICATE of bug 29165
18 years ago
17 years ago

People

(Reporter: Warren Harris, Assigned: Dan M)

Tracking

({helpwanted, pp})

Trunk
x86
Linux
helpwanted, pp
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
I typed d:/temp/foo.html into my location bar on Windows (note: not 
d:\temp\foo.html) and got a dialog saying "d is not a registered protocol" -- 
fine. But then I hit return to dismiss the dialog, and not only did the dialog 
dismiss, but the return got entered into the location bar again causing another 
one of these dialogs to come up. It seems to me that hitting the return in the 
dialog should eat the return.

Comment 1

18 years ago
reproduced using today's verification build on Win98, reassigning to danm as p4
for m18, helpwanted
Assignee: trudelle → danm
Keywords: helpwanted
Priority: P3 → P4
Target Milestone: --- → M18

Comment 2

18 years ago
Mass moving M18 bugs to M19
Target Milestone: M18 → M19

Comment 3

18 years ago
*** Bug 35005 has been marked as a duplicate of this bug. ***

Comment 4

18 years ago
No such problem seen with the 2000-04-25-12-M16 nightly binary on WinNT 4.0.
The dialog dismisses fine, no reload, even if the [Ok] button is positioned
just over the URL bar. This may be a DUP of a bug that got fixed, if memory 
serves.

Comment 5

18 years ago
*** Bug 37270 has been marked as a duplicate of this bug. ***

Comment 6

18 years ago
also cannot repro on 2000042608 win2k or win98. i recall recently a similar bug 
was filed and fixed regarding preferences (hitting enter on the prefs screen 
could also submit an HTML form), I don't know if the fix for that affected this 
(it wouldn't seem likely).  In any case, marking wfm for now.  reopen if 
necessary.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME
(Assignee)

Comment 7

18 years ago
It's been fixed somehow on Windows, but it's still a problem on Linux (but not on 
the Mac, PS).
Status: RESOLVED → REOPENED
OS: Windows NT → Linux
Resolution: WORKSFORME → ---

Comment 8

18 years ago
pp
Keywords: pp

Comment 9

18 years ago
This works for 2000050808 win95, 2000050808 mac, 2000050811 linux. 
But this is a dupl of bug 29165 anyways.

*** This bug has been marked as a duplicate of 29165 ***
Status: REOPENED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → DUPLICATE

Comment 10

18 years ago
Verified duplicate.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.