Tools -> Account Settings -> Server Settings -> Advanced feature appears broken

RESOLVED WONTFIX

Status

Thunderbird
General
RESOLVED WONTFIX
12 years ago
10 years ago

People

(Reporter: Ocie Hudson, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.2) Gecko/20060308 Firefox/1.5.0.2
Build Identifier: Thunderbird 1.5.0.2 (20060308)

Please read http://kb.mozillazine.org/Global_Inbox with particular attention to Section 4 Other Information, which begins with:

"Accounts that use the Global Inbox are sometimes called 'deferred' accounts, and it is possible to create deferred accounts that do not use Local Folders for the Global Inbox. For example, if you have three Gmail accounts, you could set up two of them to store their mail together with the mail for the other Gmail account but outside of Local Folders. To do so, follow the procedure above for setting the destination Inbox, but instead of selecting 'Global Inbox (Local Folders Account)', select 'Inbox for a different account' and then from the dropdown list choose the account you want to use."

When I have attempted to do this, to divert incoming e-mail from Account A (profile A) to another, Account B (profile B), with TBird accessing the files for Account A, the Advanced panel shows three choices, each preceeded by a radio button:

   o Inbox for this server's account
   o Global Inbox (Local Folders account)
   o Inbox for different account [DROPDOWN LIST]

The dropdown list for the third option has only two choices:  "Local Folders" and the name of Account A, to which the first option applies.  It does not include the name of Account B or any other account(s).  If the documentation is 
wrong, then that is a very serious matter, because I've bet quite a lot of time and effort in the belief that it is correct -- not the least of which has been spent reviewing extant bug reports before filing this one.

Reproducible: Always

Steps to Reproduce:
1. Create a profile for Account A (POP3 server).
2. Create a profile for Account B (same POP3 server).
3. With TBird accessing the files for Account A, (attempt to) use the Tools -> Account Settings -> Server Settings -> Advanced feature to  divert e-mail for Account A to the inbox for Account B, as described -- i.e., you can't do it.

Actual Results:  
The choices presented on the dropdown list are the same as the two other respective options that precede it, as described.

Expected Results:  
It should show the other account, i.e., the account for the other profile, on the dropdown list, but TBird seems to not know that it exists.

I can understand why TBird or any other e-mail client should tiptoe around files that are stored in the Windows XP "Documents and Settings" directory.  If the "ownership" of the various files is not perfectly respected, the consequences can be rather severe (for example, files that have _no_ owner cannot be accessed for any reason at all, so the user ends up with files that can't be deleted, moved, copied, etc.).  Still, since the Windows XP user account is the same for both profile file-sets, there should not be any problem specifying the other profile's inbox as the destination for a profile's e-mail.

Comment 1

12 years ago
You want to store your incoming mail in another profile? We don't support that, for the reasons you describe. We just support storing incoming mail in different accounts within the same profile. I wouldn't describe that as "broken" - it's by design. Nothing in the Mozillazine article says anything about multiple profiles - it simpy talks about multiple accounts within the same profile. A given profile knows NOTHING about any other profile.

Comment 2

12 years ago
the reporter made the same error in bug 335221
(Reporter)

Comment 3

12 years ago
The Mozillazine article to which I referred does not say anything about profiles, about whether the respective accounts must be within the same profile (which does not seem to be possible) or whether they can be within different profiles.  It ignores the matter of profiles entirely.  The main subject of the article is the so-called "Global Inbox" which has some sort of relationship to the "Local Folders" that doesn't, frankly, make sense.  Thunderbird has no native "Help" as standard Windows applications customarily do, and what is disclosed about it seems to be located entirely on the Mozilla complex of websites.  I've read enough articles to know by now that the person who wrote the one I'm reading more often than not does not, in fact, either know what they're talking about or has no evident ability to share what they know in writing.  That's an unfortunate situation, but I'm beginning to think that Outlook Express might not be so bad after all.

Comment 4

12 years ago
Ocie: profiles have nothing to do with accounts. They're just a way to provide different settings for different people for example, when sharing the same windows-logon. Each profile defines what account on what mailserver it uses (or more than one).
(Reporter)

Comment 5

12 years ago
Regarding Comment #4:  The online documentation that I read about multiple accounts told how to set up an additional account(s) by creating an additional profile(s).  It did NOT mention any other possibilities, unlike the article from which I quoted about the Global Inbox.  Even that article can be readily construed as implying that the Global Inbox is necessary to have multiple accounts (it also fails to mention that the accounts must all be under the same profile for the Global Inbox to be such) -- at least until you read Section 4 Other Information.  Last, but not least, the start of the software implementation for creating an additional account(s) is hidden away on a submenu of the main File menu, and at the bottom of the lower left column on Tools -> Account Settings where all attention is focused on the upper righthand corner.  IMHO, it would be best if TBird had an "Accounts" entry on the main toolbar, equal to "File", "View", etc., even if the menu begins with just one entry. :-)

Comment 6

11 years ago
Ocie, kb articles can be edited, so if you see something in http://kb.mozillazine.org/Global_Inbox that is not correct you can certainly edit it based on well tested experience to improve the information.

david is there something worth keeping for possible ENH (I don't see anything based on your comment 1), or is this WONTFIX?  
Wayne, still a bug?

Comment 8

10 years ago
I don't do global inbox, so I can't reasonably say.  Someone must judge based on what they see here or what they can test.
(Reporter)

Comment 9

10 years ago
Please note that I was running version 1.5.0.2 (20060308) at the time that I reported this problem almost two years ago.  Currently, I am running version 2.0.0.14 (20080421).  User profiles are currently handled in a completely different manner --with a separate program, it seems to me-- than they were when I reported this problem.

Currently, I have a primary e-mail account with Embarq and three sub-accounts for it (each of the four having a different e-mail address).  I have configured my only TBird profile to have messages that are sent to the primary address stored in the inbox for its corresponding account, and messages sent to each of the subaccounts are stored in the Global Inbox.  

From re-reading what I reported, a large part of the problem was that the online documentation was inconsistent, whether outright incorrect:  that I must not only create two e-mail accounts but also each one for a different profile, and I would have the option to have e-mail for one redirected to the inbox of the other.  That might have been true for some version(s) of the software.  But I found that it was not possible to redirect messages from the account of one profile to the account of another.  Note also that (if memory serves), the documentation stated that only one e-mail address could be designated for each profile.  That might have been true for some prior versions, but, as far as I can determine, that is not true with regard to the current version. (I can see how Comment #1 is, or should be, correct.) 

Insofar as I can determine, we cannot redirect the mail addressed to an account of one profile to the inbox of an account for another profile.  However, we can have multiple accounts for any profile(s), so I no longer perceive that there is a problem (unless the documentation does not match what we can do with the software!).
Status: UNCONFIRMED → RESOLVED
Last Resolved: 10 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.