Navigator crashes at a web page (with talkback ID)

RESOLVED WORKSFORME

Status

--
critical
RESOLVED WORKSFORME
13 years ago
13 years ago

People

(Reporter: tetsuji.rai, Unassigned)

Tracking

Trunk
x86
Linux

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

13 years ago
Seamonkey crashes by visiting Intel's forums.  I use these forums frequently and I've never seen this crash before.

This crash doesn't always happen, but it happens with my own build also.

Talkback id is TB17908483Q, and my nightly build is 2006042301.
(Reporter)

Comment 1

13 years ago
Another crash.  TB17908794Q.

This time it crashed while I browsed the forums.  Doesn't seamonkey like these pages?  I encountered some crashes at other Intel's pages.
(Reporter)

Comment 2

13 years ago
I tried this on another Gentoo Linux box and I cannot reproduce it.  

Now I am suspecting the Linux itself, because I recently upgraded the whole system on the problematic miachine, especially glibc is dubious...

For the time being, I close, and if it persists, I'll reopen.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 3

13 years ago
I tried with release 1.0.1 on my quetionable system, but I had no crash;ie, I have crashes only with nightly build.  So I guess this is a problem of mozilla side and reopen this issue.

Another two talkback id's (if necessary) TB17911239W and TB17911606W.
Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
(Reporter)

Comment 4

13 years ago
Finally it crashes to open bookmarked google's main page or gmail.  (bookmarked as http://www.google.com).   TB17912998W and TB17913018H both for www.google.com.

I cannot believe it.
(Reporter)

Comment 5

13 years ago
I tried seamonkey release 1.0.1 open www.google.com and got a crash.  This may be due to my system....?   Where am I getting crash (segfault)??  In libc or in seamonkey or in any other library?

Comment 6

13 years ago
jay: why aren't there stack traces? :(

reporter: after you start seamonkey, try this (in a terminal window):
ps aux|grep seamonkey-bin
cd _directory_containing_seamonkey_bin
gdb ./seamonkey-bin
attach {pid listed by ps}
handle SIG32 noprint
handle SIG33 noprint
handle SIG34 noprint
cont

continue using seamonkey as usual. after it crashes, go back to the terminal window and type:
where

copy the output from the terminal window to this bug (starting w/ the received signal line).
(Reporter)

Comment 7

13 years ago
Good point!!  I forgot that way.

when it crashes, gdb says:

     eax:00000013 ebx:B74DC1B0  ecx:09675380  edx:09675310     eflags:00010292
     esi:09675840 edi:00000006  esp:BFE59AEC  ebp:00000013     eip:B74D5B80
     cs:0073  ds:007B  es:007B  fs:0000  gs:0033  ss:007B    o d I t S z A p c
[007B:BFE59AEC]---------------------------------------------------------[stack]
BFE59B1C : 01 00 00 00  B0 10 09 08 - 00 00 00 00  84 13 64 B7 ..............d.
BFE59B0C : E4 30 93 08  C0 D5 5A 09 - 00 00 00 00  84 45 64 B7 .0....Z......Ed.
BFE59AFC : 10 11 5E 09  60 D4 5D 09 - B0 7B 4D 08  60 AB 56 B7 ..^.`.]..{M.`.V.
BFE59AEC : 00 00 00 00  04 9B E5 BF - 78 38 2C 08  B3 CC 4E B7 ........x8,...N.
[007B:09675840]---------------------------------------------------------[ data]
09675840 : 00 00 00 00  00 00 00 00 - 00 00 00 00  00 00 00 00 ................
09675850 : 00 00 00 00  00 00 00 00 - 00 00 00 00  00 00 00 00 ................
[0073:B74D5B80]---------------------------------------------------------[ code]
0xb74d5b80 <inflateBack+11325>: movdqa %xmm0,0xb0(%esp)
0xb74d5b89 <inflateBack+11334>: movdqa %xmm0,0xc0(%esp)
0xb74d5b92 <inflateBack+11343>: test   %ebp,%ebp
0xb74d5b94 <inflateBack+11345>: je     0xb74d5d0c <inflateBack+11721>
0xb74d5b9a <inflateBack+11351>: lea    0xffffffff(%ebp),%ecx
0xb74d5b9d <inflateBack+11354>: and    $0x7,%ecx
------------------------------------------------------------------------------
0xb74d5b80 in inflateBack () from /lib/libz.so.1
gdb> bt
#0  0xb74d0b80 in inflateBack () from /lib/libz.so.1
#1  0xb3d242f0 in ?? ()
#2  0xb3d3e720 in ?? ()
#3  0xb3f773a8 in ?? ()
#4  0xb7565b60 in ?? () from /usr/lib/libfreetype.so.6
#5  0xb206848c in ?? ()
#6  0x08af9a68 in ?? ()
#7  0x00000000 in ?? ()

hmmm...I cannot spot where in inflateBack() it is...(it's in mozilla/security/nss/cmd/zlib/infback.c)  I seem to compile with debug..? hmmm....$#@!$#@!
(Reporter)

Comment 8

13 years ago
I don't want to go back to glibc-2.3.6.   (but seamonkey seems to work with glibc-2.3.5).

So I will compile with debug info and spot where segfault occurs.
(Reporter)

Comment 9

13 years ago
hmm...I feel like going back to glibc-2.3.6....and try.
(Reporter)

Comment 10

13 years ago
Since I reinstalled my system, seamonkey works fine.   This seems to be due to my system!!  Sorry...
Status: REOPENED → RESOLVED
Last Resolved: 13 years ago13 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.