Text in input control doesn't scroll with the caret

RESOLVED FIXED

Status

()

Core
Editor
--
major
RESOLVED FIXED
12 years ago
12 years ago

People

(Reporter: Vladislav Duma, Assigned: Joe Francis)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060411 SeaMonkey/1.5a
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060411 SeaMonkey/1.5a

The caret in an input control should be always visible.
However if the text in the input control is long enough, the caret goes off the visible part, the text is not scrolled automatically to make the caret visible.

Reproducible: Always

Steps to Reproduce:
1. Open some web page with <input type="text"> control on it. For example, http://www.mozilla.org
2. Type into input control more text than fits into its width. (For example, into "search mozilla" search field.)


Actual Results:  
The caret goes past the right border of the input control.

Expected Results:  
It should stay at the right border, the text should have been scrolled leftwards.

The bug occurs only in the last Seamonkey nightlies.
Switching to the clean profile didn't help.
(Reporter)

Comment 1

12 years ago
Changed version to "trunk".
Version: unspecified → Trunk

Comment 2

12 years ago
worksforme with linux seamonkey trunk build 2006042410
Assignee: guifeatures → mozeditor
Component: XP Apps: GUI Features → Editor
Product: Mozilla Application Suite → Core
(Reporter)

Comment 3

12 years ago
Cannot reproduce the bug anymore with build ID 2006042608.
Mark as WORKSFORME?
Fixed by bug 334608
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED
You need to log in before you can comment on or make changes to this bug.