Can no longer customize which columns are visible in the thread pane

VERIFIED FIXED

Status

SeaMonkey
MailNews: Message Display
P1
critical
VERIFIED FIXED
18 years ago
13 years ago

People

(Reporter: Simon Fraser, Assigned: David Hyatt)

Tracking

({crash, regression, topcrash})

Trunk
crash, regression, topcrash

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [nsbeta2-])

(Reporter)

Description

18 years ago
If I try to use the popup menu to hide some columns in the thread pane, I start 
to hit a whole load of assertions:

###!!! ASSERTION: bad arg, col index out of bounds: 'numCols > aColIndex', file 
nsTableFrame.cpp, line 3696
###!!! ASSERTION: invalid number of columns: 'colX < numCols', file 
nsTableFrame.cpp, line 1482
###!!! ASSERTION: nsCellMap::GetNumCellsOriginatingInCol - bad col index: 
'PR_FALSE', file nsCellMap.cpp, line 400

and the settings don't seem to stick.

Comment 1

18 years ago
Same as http://bugzilla.mozilla.org/show_bug.cgi?id=33388.  Want me to mark the 
other one a dup of this since this bug as assertion information?
(Assignee)

Comment 2

18 years ago
We should track down when this went bad.  I haven't touched trees in ages... 
karnaze, have you landed something lately?

Comment 3

18 years ago
reassigning to karnaze.  The stack for these assertions is full of table code so
it's hopefully not a mailnews bug.
Assignee: putterman → karnaze
Rewriting this bug with the necessary info from Bug 33388, prior to closing it 
as a dupe. Please see that bug for a detailed description of the failure 
behaviour, plus a Windows crash report.

This is a regression between 20000323 and 20000324.

Gerv
Severity: normal → major
Keywords: crash, regression
OS: Mac System 8.5 → All
*** Bug 33388 has been marked as a duplicate of this bug. ***

Comment 6

18 years ago
I have been working on the table frame construction rewrite and haven't checked 
anything in for over a week. The last time I changed layout (excluding 
tables) was to fix the compatibility mode problem (checked in 3/20, I think) but 
that should not have affected this. I'm CCing pierre, dbaron, cmanske because 
they have touched table code recently. Pierre did something on 3/17 affecting 
visibility but the bug says the regression occured between 3/23 and 3/24. I 
won't be able to look at this until I finish the frame construction. 

Updated

18 years ago
QA Contact: lchiang → nbaca

Comment 7

18 years ago
I looked at what I added and at the stack and don't see any way my changes 
could have caused this. I'd vote for the changes that affected visibility!

Comment 8

18 years ago
*** Bug 33677 has been marked as a duplicate of this bug. ***
It seems the Bookmark team had this exact problem (at least, going back a few 
builds and trying it shows it being exactly the same symptoms). Their work, and 
fix, is documented in bug 30152, and seems quite simple. Their columns now work 
(20000328). You might want to check that out.

Gerv

Comment 10

18 years ago
In the pane that lists the messages, I clicked on the arrow to the far left and 
tried excluding the date and it did not disappear. Instead, the arrow 
disappeared and would not reappear again. I didn't try deleting mozregistry.dat 
or usr50, but that is probably required.

I'm not seeing any assertions, which could be due to the new table frame 
construction or something else. Viewer test4 exhibits working collapsed cols, 
so I'm not sure what is going on and find it almost impossible to test.

Hyatt, you must have some insight on how this works and a possible reduced test 
case.
Assignee: karnaze → hyatt
(Assignee)

Comment 11

18 years ago
This is because of a rule added to xul.css 

*[hidden="true"]

Since the tree widget used hidden for something other than "display: none", 
which is what the xul.css rule does, it is now broken because this rule is 
coming into effect.
Status: NEW → ASSIGNED
(Assignee)

Updated

18 years ago
Target Milestone: --- → M16

Comment 12

18 years ago
Mass-moving all M16 non-feature bugs to M17, which we now consider to be part 
of beta2.
Target Milestone: M16 → M17
(Assignee)

Comment 13

18 years ago
*** Bug 30152 has been marked as a duplicate of this bug. ***

Comment 14

18 years ago
*** Bug 35177 has been marked as a duplicate of this bug. ***

Comment 15

18 years ago
No change in build 41205, still hard crash in kernel32.dll

Comment 16

18 years ago
*** Bug 36032 has been marked as a duplicate of this bug. ***

Comment 17

18 years ago
No longer crashes in kernel32.dll as I reported on 4/12. However, the bug 
persists as noted, options not available. Context menu arrow appears when 
mail/news first loads, menu appears, option is clicked on but action produces no 
results. From then on the context menu is no longer available, arrow disappears.

Comment 18

18 years ago
*** Bug 36496 has been marked as a duplicate of this bug. ***

Comment 19

18 years ago
If bug 30152 really is a dupe of this bug then the bookmakrs testcase outlined there will have to be verified as well, cc'ing myself. 
Currently that test still results in a crash.

Comment 20

18 years ago
*** Bug 36653 has been marked as a duplicate of this bug. ***

Comment 21

18 years ago
*** Bug 37346 has been marked as a duplicate of this bug. ***

Comment 22

18 years ago
*** Bug 38011 has been marked as a duplicate of this bug. ***

Comment 23

18 years ago
upping severity due to crash. submitting for nsbeta2 since this is an easily accessible, easy to reporduce crash that affects several 
components in the products (bookmarks, search, mail) and anything that uses that little triangle widget. The dupes have 
alternate testcases.
Severity: major → critical

Comment 24

18 years ago
removing my name

Comment 25

18 years ago
adding nsbeta2 to keyword per claudius' comment.
Keywords: nsbeta2

Comment 26

18 years ago
Claudius, PDT would like you to retest to see if it still crashes.
Whiteboard: [NEED INFO]

Comment 27

18 years ago
It is a pleasure to serve my PDT...

I reproduced the dupes (Bookmarks, search) rather easily with the 2000051508 builds on NT. Does it still crash? Yes, much.
I couldn't quite repro the mail case, it seems there might be other bugs blocking, Ninoschka might know more than in that
case.

Comment 28

18 years ago
clearing "Need info" from status whiteboard since Claudius able to reproduce the 
bug.  The mail case isn't specifically needed for PDT team since Claudius able 
to reproduce other cases, but we'll try anyway.  Ninoschka?
Whiteboard: [NEED INFO]

Comment 29

18 years ago
Build 2000-05-12-10M16: Win95, Linux 6.0, Mac 9.04

Here are some mail scenarios but none of them resulted in a crash but would like 
the ability to view or not view columns to work as expected:

- Remove the Thread column using the column selector widget but the Sender 
column is an odd size. Reported in bug# 38239.

- Tried removing the Priority column which results in the column remaining but 
now the column header displays as "...". Also, the Total column and selector 
widget are removed.

- Removed the following columns result in the column remaining, also the Total 
and selector widget are removed:
  - date
  - flag
  - unread
  - size

Comment 30

18 years ago
Putting on [nsbeta2+][6/01] radar.  This work must be done by 06/01 or we may 
pull this for PR2.
Whiteboard: [nsbeta2+][6/01]

Comment 31

18 years ago
Changing from [6/01] to [6/15]
Whiteboard: [nsbeta2+][6/01] → [nsbeta2+][6/15]

Comment 32

18 years ago
Mass-moving all dated nsbeta2+ bugs to M19
Target Milestone: M17 → M19

Comment 33

18 years ago
*** Bug 40592 has been marked as a duplicate of this bug. ***

Comment 34

18 years ago
bug 40592 has a nice current stack for the Mac crash in bookmarks.
Currently this bug has got a dozen dupes (transitive closure).
Adding mostfreq keyword.
Keywords: mostfreq

Updated

18 years ago
Keywords: topcrash

Comment 36

18 years ago
*** Bug 40181 has been marked as a duplicate of this bug. ***
*** Bug 41484 has been marked as a duplicate of this bug. ***

Comment 38

18 years ago
*** Bug 41625 has been marked as a duplicate of this bug. ***

Comment 39

18 years ago
*** Bug 33221 has been marked as a duplicate of this bug. ***

Comment 40

18 years ago
p1
Priority: P3 → P1

Comment 41

18 years ago
Cleaning up status whiteboard by marking beta2 minus (6/15 has passed)

Does the tree-rewrite take care of this bug??  I'm guessing bug is pretty 
significant, and nominating for beta3.
Keywords: nsbeta3
Whiteboard: [nsbeta2+][6/15] → [nsbeta2-]
(Assignee)

Comment 42

18 years ago
fixd.
Status: ASSIGNED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → FIXED

Comment 43

18 years ago
Build 61920

Not fixed. Drop down context menu works now but UNselected columns remain even 
after program termination/restart. Also, now cannot resize column width, grab 
handle is missing.
Reopening based on jay's comments.

Gerv
Status: RESOLVED → REOPENED
Resolution: FIXED → ---

Comment 45

18 years ago
Works fine for me on 2000-06-20-08 commercial M17 build on NT. Jay, are you
actually using a build with this bug fixed? Based on the timestamp of your
comment, I'm wondering. Ninoschka, could you look into this?
(Assignee)

Comment 46

18 years ago
This is fixed.
Status: REOPENED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → FIXED

Comment 47

18 years ago
Fixed for the most part in build 62020. However, the column width still cannot
be changed, missing grab handle. Will file separate bug on this. THANKS

Comment 48

18 years ago
jay - the column width / resize columns is already a bug that's been filed.

Comment 49

18 years ago
Build 2000-06-20-09M17: NT4, Linux 6.0, Mac 9.04
Verified Fixed. The assertion is not happening. 

Also the column selector widget is present. I can deselect a column (i.e. 
thread, subject, date...) and the column does not display as expected. The 
column selector widget is still present and I can reselect the column to make it 
display again. The problem with resizing the column width is in bug# 41357.
Status: RESOLVED → VERIFIED

Comment 50

18 years ago
This is not fixed.  Tested on Linux build 2000062116.

To reproduce:

With Subject and Thread selected:

1. De-select Subject
2. Re-select Subject.

Browser crashes with "pure virtual method called" error message.

Comment 51

18 years ago
Stephen: I could not reproduce it on the Mac and it doesn't sound like it's the 
same bug. Please open a separate bug report. 
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.