Ratings not updated since comment overhaul

VERIFIED FIXED

Status

addons.mozilla.org Graveyard
Public Pages
--
critical
VERIFIED FIXED
12 years ago
2 years ago

People

(Reporter: Daniel Steinbrook, Assigned: morgamic)

Tracking

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
User-Agent:       Opera/9.00 (Windows NT 5.0; U; en)
Build Identifier: 

Ever since the new comment features were added, new comments are not contributing to the overall rating.  For instance, my Redmond revisited theme (see URL) was approved after the comment management changes and had since recieved three comments, but the theme still reporst no rating.

Reproducible: Always

Steps to Reproduce:
Rate an extension or theme (any extension or theme), and give it a rating

Actual Results:  
The overall extension/theme rating does not change.

Expected Results:  
The rating should display an average of all ratings.

No rating is reported in the developer control panel, either.

Updated

12 years ago
Status: UNCONFIRMED → NEW
Ever confirmed: true
Target Milestone: 1.0 → ---
Version: unspecified → 2.0

Comment 1

12 years ago
Confirming, same case with Mouse Gestures. The "average" rating of 4.73 did not change in the last weeks, although several 5-star-ratings were made.

Updated

12 years ago
Assignee: morgamic → nobody
Component: Public Pages → Maintenance Scripts
QA Contact: web-ui → maintenance
(Assignee)

Comment 2

12 years ago
*** Bug 343965 has been marked as a duplicate of this bug. ***
(Assignee)

Comment 3

12 years ago
I had originally planned on putting this into the maintenance script as an added function, but it would be pretty easy to just add the update for the lookup in the addcomment script.
Assignee: nobody → morgamic
Severity: major → critical
Component: Maintenance Scripts → Public Pages
(Assignee)

Comment 4

12 years ago
Created attachment 228551 [details] [diff] [review]
Patch to update rating lookup in `main` when a new comment is added.
(Assignee)

Updated

12 years ago
Attachment #228551 - Flags: first-review?(clouserw)

Updated

12 years ago
Attachment #228551 - Flags: first-review?(clouserw) → first-review+
(Assignee)

Comment 5

12 years ago
This has been checked in.  It will be updated today.
Status: NEW → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED

Comment 6

12 years ago
As the ratings for Mouse Gestures and Footiefox have now changed, I'm verifying this :)
Status: RESOLVED → VERIFIED
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.