Browser repeatedly hangs for a few seconds and resumes usability

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
13 years ago
12 years ago

People

(Reporter: ewwallace, Unassigned)

Tracking

1.5.0.x Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: CLOSEME)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 1.1.4322; .NET CLR 2.0.50727)
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.2) Gecko/20060308 Firefox/1.5.0.2

I've had a perplexing problem with both Firefox v1.5.0.1 and 1.5.0.2 that makes it impossible to use on this PC alone (I use it on all other PCs without a problem).

During browsing, the Firefox process will hang momentarily--for 2 to 10 seconds--not allowing me to do anything inside the Firefox window, then it will resume normal behavior as if nothing happened. During these freeze-up, I can switch to other applications, which are working fine; and Task Manager says the FIREFOX.EXE process is using 0% processor.

Here are some symptoms:
- hover states no longer function and the cursor stops changing
- the Firefox branded icon in the upper-right corner temporarily changes to a generic executable icon
- the window title may add the words "(Not Responding)"

Things I've done to try to solve the problem:
- run Safe Mode
- disable or uninstall Extensions (this happened before I had installed any)
- new profile
- uninstall and reinstall Firefox
- remove/disable any interfering programs (anti-virus, etc.)

This PC doesn't have any memory or networking problems that effect other browsers or applications in this manner.

Reproducible: Sometimes

Steps to Reproduce:
1. Open a web page
2. Click links to browse to different pages. Move the mouse over links to watch for hover state.
3. Observe as the browser (only) becomes unresponsive: cannot click or do anything in Firefox during this time.
4. Wait a few seconds until usability is restored.
Actual Results:  
As described above

Expected Results:  
You know how browser performance is typically... It may slow while loading pages especially in the background, but it not normally like this.

This problem has persisted thru versions 1.5.0.1 and 1.5.0.2 on this PC only. Oddly enough, it seemd to stop for one week, and I resumed using Firefox (since I find it hard to live without!)--but then after the v1.5.0.2 update, the hanging behavior started again.
(Reporter)

Comment 2

13 years ago
(In reply to comment #1)
> See http://kb.mozillazine.org/Firefox_hangs

Thx... I'd gone thru the "standard diagnostic" but hadn't found the "hangs" page. Trying the applicable ones now on a clean profile...

So far the only likely one is the hyperthreading, which so far _seems_ to be working, but I've also had one firefox.exe crash! Arrrghh...
Reporter, do you still see this problem with Firefox 2.0? If not, can you please close this bug as WORKSFORME. Thanks!
Whiteboard: CLOSEME
Version: unspecified → 1.5.0.x Branch
(Reporter)

Comment 4

12 years ago
Yup... the current Firefox 2.0.x series does not have this issue for me; sorry for the delay in closing the bug report--oops! Thanks all for your comments, and keep up the good work.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.