RSS Subscription will not allow resubscrition to a deleted feed

RESOLVED DUPLICATE of bug 309449

Status

RESOLVED DUPLICATE of bug 309449
13 years ago
10 years ago

People

(Reporter: bugs, Assigned: mscott)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.2) Gecko/20060308 Firefox/1.5.0.2
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.2) Gecko/20060308 Firefox/1.5.0.2

I deleted a feed by using the feed tree and using "Delete Folder". Then I emptied the trash.

I tried to resubscribe to the feed and I get the Alert Box - "You are already subscribed to this feed" yet the feed does not appear in the feed list.

I restarted Thunderbird and tried again with the same result.


Reproducible: Always

Steps to Reproduce:
1.Subscribe to feed
2.Delete the folder using the folder tree and right mouse menu
3.Try to resubscribe to the feed

Actual Results:  
Alert box - "You are already subscribed to this feed"

Expected Results:  
Resubscribe to feed
To unsubscribe you should have used Manage Subscriptions, xref bug 267082 (close dupe?)
(Reporter)

Comment 2

13 years ago
Great I know that now but how do I fix it so that I can resubscribe? And why does Thunderbird allow you to delete a folder before a subscription is removed?

Is there a work around to allow me to resubscribe?
(In reply to comment #2)
> Is there a work around to allow me to resubscribe?

Not an easy one, but see bug 267082 comment 6. I think you should also remove relevant entries from feeditems.rdf. 

(Reporter)

Comment 4

13 years ago
All fixed thanks. (Close now?)
This was actually a duplicate.

*** This bug has been marked as a duplicate of 309449 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE

Updated

10 years ago
Component: RSS → Feed Reader
Product: Thunderbird → MailNews Core
You need to log in before you can comment on or make changes to this bug.