= : etc. are not reserved chars in an URL path and should not be escaped

VERIFIED WORKSFORME

Status

()

Core
Networking
P3
normal
VERIFIED WORKSFORME
18 years ago
17 years ago

People

(Reporter: John Lacey, Assigned: Gagan)

Tracking

Trunk
x86
Windows NT
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; N; NT4.0; en-US) Mozilla/m13
BuildID:    2000022820

According to RFC 2396, a character in a path segment (pchar) is defined as
unreserved | escaped | ":" | "@" | "&" | "=" | "+" | "$" | ","
I think that an HTTP URL path may validly be escaped but Mozilla is escaping
things that IE and Netscape do not, e.g., /qmethod=v is escaped by M14. It
happens in this case that Autonomy software uses HTTP with a relative URL such
as this, but does not understand the escaped /qmethod%3Dv. I *think* that this
is a bug in Autonomy, but I also think that Mozilla is overzealous in its URL
escaping.


Reproducible: Always
Steps to Reproduce:
1. Enter an URL with = or : in the path, e.g., /qmethod=v

Actual Results:  See that Mozilla escapes = as %3D, viz., /qmethod%3Dv

Expected Results:  Left it alone, e.g., /qmethod=v

Comment 1

18 years ago
It's a bug in Autonomy, it should be able to deal with escaped characters.

Anyway, johnl@vizdom.com, can you test this with a recent build? Moz seems to 
leave the = alone in 
today's build on my Win 95.
(Reporter)

Comment 2

18 years ago
This works for me, too, in M15 (2000041805) on NT.

Comment 3

18 years ago
Marking it WFM
Status: UNCONFIRMED → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME

Comment 4

17 years ago
Works for me:
Platform: PC
OS: Windows 98
Mozilla Build: 2000101014 M18 Trunk Build

Marking as Verified.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.