cant create certificate request using GemSAFE USB crypto device

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
13 years ago
8 years ago

People

(Reporter: sharapanoff, Unassigned)

Tracking

2.0 Branch
x86
Windows Server 2003
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.2; en) Opera 9.00
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.2; en-US; rv:1.8.0.1) Gecko/20060111 Firefox/1.5.0.1

i've installed crypto module gclib.dll (ver. 31003.2.20001.0 ) 
and i cant create certificate request



Reproducible: Always

Steps to Reproduce:
use html like this:
<html><body><form>
<keygen name="testkey" challenge="none" keytype="RSA">
<input type="submit">
</form></body></html>

after submit, GemSAFE
Actual Results:  
1024 (Medium Grade)

Expected Results:  
something like this:
MIIBPjCBqDCBnzANBgkqhkiG9w0BAQEFAAOBjQAwgYkCgYEAu0rxSdnGgemfRhZ+ iJpHpHFRlAKgsA0a8U1P2p0HLZNcjrYPT9AviPM+DsofEmFV3lwWFv22AYrJPNsl 8tMqavukJsTNnIxLujZhAkFGtHJKGA7WINKLezq6S2dyPOnFgXSEngjwTxeIfjpd Tio/p+zml9RSREgjTWZ8O0q5+U8CAwEAARYEbm9uZTANBgkqhkiG9w0BAQQFAAOB gQCYryWoWETYqfUiCiRduUHM8Hnnkh9MnmyhxRMq9XkFnug6Hf01RyVZzVwwh8LY Bk4+z8pgJpuqmVPvXa4kcYrRN9NVl/OalTkqtYeoDBOpMxP6j+ZXAwMdR6S1vf9w xkm7y7Ggh3dkOIkzrik8BzDfvXAhSiRCFpB82kxWPS/8AQ==

using xenroll in IE it works, so it is not the usb device problem, probably the problem is in the use of gclib...
the crtificates that are on the device are OK - they are listed in certificates listbox of firefox
Reporter, do you still see this problem with the latest Firefox 2? If not, can you please close this bug as WORKSFORME. Thanks!
Whiteboard: CLOSEME 06/27
Version: unspecified → 1.5.0.x Branch
(Reporter)

Comment 2

11 years ago
Yes, i still see this problem ( Firefox 2.0.0.4 )

Updated

11 years ago
Whiteboard: CLOSEME 06/27
Version: 1.5.0.x Branch → 2.0 Branch
This bug was reported on Firefox 2.x or older, which is no longer supported and will not be receiving any more updates. I strongly suggest that you update to Firefox 3.6.3 or later, update your plugins (flash, adobe, etc.), and retest in a new profile. If you still see the issue with the updated Firefox, please post here. Otherwise, please close as RESOLVED > WORKSFORME
http://www.mozilla.com
http://support.mozilla.com/kb/Managing+profiles
http://support.mozilla.com/kb/Safe+mode
No reply, INCOMPLETE. Please retest with Firefox 3.6.x or later and a new profile (http://support.mozilla.com/kb/Managing+profiles). If you continue to see this issue with the newest firefox and a new profile, then please comment on this bug.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → INCOMPLETE
(Reporter)

Comment 5

8 years ago
Unfortunately, currently i'm not using GemSAFE.
Resolution: INCOMPLETE → FIXED

Updated

8 years ago
Resolution: FIXED → WORKSFORME
You need to log in before you can comment on or make changes to this bug.