Closed Bug 335577 Opened 19 years ago Closed 18 years ago

MSAA info for messages list gets lost after changing folders.

Categories

(Thunderbird :: Mail Window Front End, defect)

x86
Windows XP
defect
Not set
major

Tracking

(Not tracked)

RESOLVED DUPLICATE of bug 246236

People

(Reporter: mzehe, Assigned: mscott)

References

Details

(Keywords: access)

Attachments

(1 file)

User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 1.1.4322; .NET CLR 2.0.50727)
Build Identifier: 1.5.0.2 (20060426)

When changing folders in Thunderbird, from the third folder onwards, MSAA info gets lost, so JAWS or another AT product can no longer read the info for the selected message.



Reproducible: Always

Steps to Reproduce:
1. Launch Thunderbird. You should have an account set up or at least one or two mail messages in your inbox.
2. Focus is on the Folder TreeView. Press TAB three times to reach the messages list.
3. Arrow up and down, and listen to JAWS telling you all about the selected message. Optionally, you can check the same info given by MSAA using HomeRow+F9, that is, press Insert+SpaceBar, F9, and listen. Press Insert+SpaceBar to turn HomeRow mode off again.
4. Shift+Tab three times to reach the folder list, and arrow down to Outbox.
5. Press Tab three times to go to the list.
6. Shift+Tab three times to get back to the folders.
7. UpArrow to Inbox. Notice that, after speaking the Inbox TreeView item, JAWS will announce "ListBox not selectd" plus the info about the first message. It would appear as though focus has moved to the messages list automatically. But in reality, focus is still on the folder tree.
8. Press Tab three times to get to the messages list.
9. Arrow up and down. Notice that JAWS will no longer read your selected item properly. Instead, it will always say "not selected", followed by some highlighted text that is part of the list entry of the currently selected message. Following the HomeRow steps above will also yield the MSAA name to be "not selected", instead of the information for the currently selected message.

Actual Results:  
When returning to the Inbox's messages list, JAWS will only speak "not selected" followed by some highlighted text, but not speak the whole message info as it did the first time.

Expected Results:  
I expected the message info to be read just as it was being read when I first was in Inbox.

I have seen this in the release version of Thunderbird 1.5.0.2 as well as the above mentioned Nightly build. As sonn as folders are changed at least once, reading the list items becomes corrupted. The only way to get functionality back, is to shut down and restart Thunderbird. Obviously, if you want to work through multiple folders, this becomes a rather tideous endeavor.

This happens regardless of whether the folders being changed are newsgroups, e-mail folders, local folders, IMAP folders.

A log generated by AccEvent32.exe from Microsoft is attached, tracking common events throughout the steps listed above.
I've seen similiar problems in tree views in Firefox. We have basically the same bug filed there somewhere. Once the contents of a tree view changes we seem to break, in terms of exposing what's in it.
Keywords: access
Sounds like bug 328273 

*** This bug has been marked as a duplicate of 246232 ***
Status: UNCONFIRMED → RESOLVED
Closed: 19 years ago
Resolution: --- → DUPLICATE
Status: RESOLVED → UNCONFIRMED
Resolution: DUPLICATE → ---
That was a typo -- the original bug is bug 246236.
Blocks: 246236

*** This bug has been marked as a duplicate of 246236 ***
Status: UNCONFIRMED → RESOLVED
Closed: 19 years ago18 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.

Attachment

General

Creator:
Created:
Updated:
Size: