Closed Bug 335583 Opened 15 years ago Closed 8 years ago

applet not executing/loading if contained in div with style="display:none"

Categories

(Core :: Plug-ins, defect)

1.8 Branch
x86
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 90268

People

(Reporter: carlemueller, Unassigned)

Details

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.2) Gecko/20060308 Firefox/1.5.0.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.2) Gecko/20060308 Firefox/1.5.0.2

I have a non-display applet (basically it's a client-side session applet) that tracks state between pages, useful for AJAX...

This wouldn't work, as in, I could not invoke methods on this applet from JavaScript scripts:

    <div style="display:none;">
      <applet id="localsession" codebase="applet" code="com.medtronic.documentum.ajax.LocalSession.class" width=0 height=0 mayscript></applet>    
    </div>

will not let the applet start. IE did start the applet. When I removed display:none, it worked. 

This may be a technicality of CSS, but I don't think it should. But what do I know. I just want any extra newlines inserted by the APPLET tag to not display (FF does not do the extra newline, but IE of course does...). 

BTW, my login email does not work anymore, please use carlemueller@yahoo.com if you need to contact me. 



Reproducible: Always

Steps to Reproduce:
1. place div around an applet that does something non-display related
2. try to reference the applet via JS 
3. JS Console says "method does not exist" for method invocation on applet
Does this work correctly on trunk?  (Trunk has a fix for bug 1156.)
Component: General → Plug-ins
Product: Firefox → Core
QA Contact: general → plugins
Version: unspecified → 1.8 Branch
Status: UNCONFIRMED → RESOLVED
Closed: 8 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 90268
You need to log in before you can comment on or make changes to this bug.