Issues with HTTPS behind Blue Coat proxy server

RESOLVED WORKSFORME

Status

()

--
major
RESOLVED WORKSFORME
13 years ago
3 years ago

People

(Reporter: iann_bugzilla, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(4 attachments)

(Reporter)

Description

13 years ago
Using SM trunk, FF trunk and FF1.5.0.2 and trying to log into Demon's webmail interface, when sitting behind an authentication proxy server (in this case Blue Coat Proxy SG server), fails and returns back to login screen with the username / password reset to being blank.
The other thing that can be seen is that the login screen looks different behind the proxy compared to when no proxy is being used. Screen shots to follow.

Also generated an nspr log file from both behind and infront of the proxy server with NSPR_LOG_MODULES=nsHttp:3
(Reporter)

Comment 1

13 years ago
Created attachment 219940 [details]
Screenshot with proxy
(Reporter)

Comment 2

13 years ago
Created attachment 219941 [details]
Screenshot with no proxy
(Reporter)

Comment 3

13 years ago
Created attachment 219942 [details]
nspr log from with proxy
(Reporter)

Updated

13 years ago
Attachment #219942 - Attachment mime type: application/octet-stream → text/plain
(Reporter)

Comment 4

13 years ago
Created attachment 219944 [details]
nspr log from with no proxy
(Reporter)

Comment 5

13 years ago
One final note this works fine behind the same proxy server using IE...
(Reporter)

Comment 6

13 years ago
Comment on attachment 219940 [details]
Screenshot with proxy

If you compare the with proxy image against the with no proxy image you will see that, despite being the same version of Firefox, the display is slightly different. There is an extra grey area above the Email name/ Host name: boxes/text in the with proxy image.
(Reporter)

Comment 7

13 years ago
Updating summary as I have checked with authentication switched off and the issue still exists.
Summary: Issues with HTTPS behind authenticating proxy server → Issues with HTTPS behind Blue Coat proxy server
Status: NEW → RESOLVED
Last Resolved: 3 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.