Caret can not be moved in/out of pull-down menu.

RESOLVED WONTFIX

Status

()

Firefox
Keyboard Navigation
RESOLVED WONTFIX
12 years ago
12 years ago

People

(Reporter: Tim Miao, Unassigned)

Tracking

({access})

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050607 Firefox/1.0.4
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20050607 Firefox/1.0.4

In caret browsing mode, user can not move caret cursor in/out of pull-down menu.

Reproducible: Always

Steps to Reproduce:
1. Launch firefox.
2. Load the page which contains pull-down menus.
3. Press F7 to switch caret browsing mode on.
4. Press arrow to browse this webpage.
5. Try to move caret focus in/out of the pull-down menus.
Actual Results:  
Failed to move caret cursor in/out of pull-down menu.

Expected Results:  
Caret cursor could be moved in/out of pull-down menu. User could make the selection to them.

This bug can be found on vermillion_39/snv_38.
I also attached the test page.
(Reporter)

Updated

12 years ago
Keywords: access
OS: Other → Solaris
Hardware: Other → Sun
(Reporter)

Comment 1

12 years ago
Created attachment 219974 [details]
test page
(Reporter)

Updated

12 years ago
Component: Disability Access → Keyboard Navigation

Comment 2

12 years ago
By design, caret only focuses document itself or links.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.