Updating extensions does not work

RESOLVED INVALID

Status

()

RESOLVED INVALID
13 years ago
10 years ago

People

(Reporter: ria.klaassen, Unassigned)

Tracking

Trunk
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

When I click "Check for updates" it doesn't find anything.
When I do the same with a build before 6 April it finds two updates.
Regression between 1.9a1_2006040609 and 1.9a1_2006040613.
http://bonsai.mozilla.org/cvsquery.cgi?module=PhoenixTinderbox&date=explicit&mindate=2006-04-06+08%3A00&maxdate=2006-04-06+13%3A00
I tested this a short while ago and it wfm. Any errors in your js console?
Also, first change the extensions.logging.enabled to true
(Reporter)

Comment 3

13 years ago
No errors present.
Can you provide the install.rdf's for those extensions or links to the xpi's to install them?
(Reporter)

Comment 5

13 years ago
Created attachment 220000 [details]
install.rdf's
ForecastFox does not have an update that is compatible with trunk though there is a newer version of ForecastFox available. I suspect you found an update when using a previous version of the app and then checked for updates with the trunk. The updateAvailableURL wasn't overwritten before and trying to install the newer version would have failed.
https://addons.mozilla.org/update/VersionCheck.php?reqVersion=1&id={0538E3E3-7E9B-4d49-8831-A227C80A7AD3}
&version=0.7.1&maxAppVersion=3.0&appID={ec8030f7-c20a-464f-9b0e-13a3a9e97384}&appVersion=3.0a1&appOS=WINNT&appABI=x86-msvc

Put those two lines back together and put it in the url bar and you will get. Note the <em:maxVersion>1.6</em:maxVersion> when the app version is &appVersion=3.0a1 and a 1.6 will not work with 3.0a1
<RDF:RDF>
<RDF:Description about="urn:mozilla:extension:{0538E3E3-7E9B-4d49-8831-A227C80A7AD3}">
<em:updates>
<RDF:Seq>
<RDF:li resource="urn:mozilla:extension:{0538E3E3-7E9B-4d49-8831-A227C80A7AD3}:0.9.0.1"/>
</RDF:Seq>
</em:updates>
</RDF:Description>
<RDF:Description about="urn:mozilla:extension:{0538E3E3-7E9B-4d49-8831-A227C80A7AD3}:0.9.0.1">
<em:version>0.9.0.1</em:version>
<em:targetApplication>
<RDF:Description>
<em:id>{ec8030f7-c20a-464f-9b0e-13a3a9e97384}</em:id>
<em:minVersion>0.10</em:minVersion>
<em:maxVersion>1.6</em:maxVersion>
<em:updateLink>
http://releases.mozilla.org/pub/mozilla.org/extensions/forecastfox/forecastfox-0.9.0.1-fx+fl+mz+ns+zm.xpi
</em:updateLink>
</RDF:Description>
</em:targetApplication>
</RDF:Description>
</RDF:RDF>

I'd have to say this is invalid though I believe you did find a previously unfixed bug in that the EM would show updates it had found in previous versions of the app that are no longer compatible in later versions of the app.
(Reporter)

Comment 7

13 years ago
(In reply to comment #6)
> ForecastFox does not have an update that is compatible with trunk
>
Ah ja, of course not. Must have been a bit distracted.
Status: NEW → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → INVALID
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.