Empty Bookmark creation when copy bookmarks from Bookmark Manager/Personal Toolbar between different processes/programs

RESOLVED WORKSFORME

Status

SeaMonkey
Bookmarks & History
RESOLVED WORKSFORME
12 years ago
6 years ago

People

(Reporter: BugFinder, Unassigned)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [2012 Fall Equinox])

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; de-AT; rv:1.8.0.2) Gecko/20060404 SeaMonkey/1.0.1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; de-AT; rv:1.8.0.2) Gecko/20060404 SeaMonkey/1.0.1

Empty Bookmark creation when i use the mouse to copy from PersonalToolbar (Firefox) to PersonalToolbar (SeaMonkey).
There was a Link then, but it was empty.


Reproducible: Always

Steps to Reproduce:
1.Mozilla Firefox Personal Toolbar - klick on Personal Bookmark
2.move (while holding left mouse button) to SeaMonkey PersonalToolbar
3.leave the link there... , but it was empty !




Mozilla Firefox Build 2006030804

Comment 1

11 years ago
If one attempts copy from FF bookmarks and paste to SM bookmarks one gets the following error**, which is possibly related to what is happening on personal toolbar.  (used current trunk versions of both). Interesting side note - try same bookmark a second time and there is no error and no new empty bookmark created.  But try a different bookmark (it pastes blank into SM), then try bookmark 1 again from FF and it pastes a blank into SM.

prob related to or a dup of another bookmark bug.

**
Error: [Exception... "Component returned failure code: 0x80070057 (NS_ERROR_ILLEGAL_VALUE) [nsIRDFService.GetResource]"  nsresult: "0x80070057 (NS_ERROR_ILLEGAL_VALUE)"  location: "JS frame :: chrome://communicator/content/bookmarks/bookmarks.js :: anonymous :: line 501"  data: no]
Source File: chrome://communicator/content/bookmarks/bookmarks.js
Line: 501
Whiteboard: dupeme

Comment 2

11 years ago
If you copy bookmarks from the bookmark manager and try to paste it to the BM of another Mozilla app like FF, SM, Moz17 (different process) you will get only empty bookmarks inserted. Windows clipboard contains the copied data as one link per line, only text. I cannot find an existing bug for this, so confirming.
Severity: trivial → normal
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Empty Bookmark creation when i copy from PersonalToolbar (Firefox) to PersonalToolbar (SeaMonkey) → Empty Bookmark creation when copy bookmarks from Bookmark Manager/Personal Toolbar between different processes/programs
Version: unspecified → Trunk

Updated

11 years ago
Duplicate of this bug: 351653

Comment 4

6 years ago
Checked, no problems dragging and copy/paste bookmarks between different SeaMonkey processes and between Firefox and SeaMonkey, closing
User agent: Mozilla/5.0 (Windows NT 6.1; WOW64; rv:18.0) Gecko/18.0 Firefox/18.0 SeaMonkey/2.15a1
Build identifier: 20120921003032
Status: NEW → RESOLVED
Last Resolved: 6 years ago
Resolution: --- → WORKSFORME
Whiteboard: dupeme → [2012 Fall Equinox]
You need to log in before you can comment on or make changes to this bug.