[RFE] opening bookmarks from manage bookmarks should open in existing browser window

RESOLVED FIXED in Future

Status

P3
enhancement
RESOLVED FIXED
19 years ago
14 years ago

People

(Reporter: croberts, Assigned: bugs)

Tracking

Trunk
Future
x86
Other

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

19 years ago
Sinners repent! Give us a preference to open or NOT open a new window when we do
File, Open new file. Opening a new window uses windows resources and is annoying
to some users.
(Reporter)

Comment 1

19 years ago
Oops. Build 2000-0327-18.
(Reporter)

Comment 2

19 years ago
Also, when I choose a bookmark (for Bugzilla) that also opens a new browser
window. Perhaps we could have an option to NEVER open a new window for any site
or local HTM file.

Opening all these browser windows clutters up my taskbar as well as uses Windows
 resources.

Updated

19 years ago
Assignee: cbegle → slamm
Component: Browser-General → Bookmarks
QA Contact: asadotzler → claudius
Summary: Choosing File, Open new file, creates new browser window → opening bookmarks from manage bookmarks should open in existing browser window

Comment 3

19 years ago
robertsc@accn,org, please limit reports to one issue.  I know these are similar
but could get assigned to different components (the first XPApps and the second
Bookmarks)  I believe that the first  is already reported as bug 22342 and the
second I can't find so I'm updating this bug Summary to reflect the Bookmarks issue.
If you want to open a bookmark from Manage Bookmarks in an existing window, the 
question is: which one? Manage Bookmarks is not associated with a particular 
window.

Gerv
robertsc@accn.org - could you look at this bug and provide an answer to the 
question posed, please? :-)

Gerv
(Reporter)

Comment 6

19 years ago
If you only have 1 browser window open it should be simple to find that window, 
and open the bookmark by using that browser window. I.e. double click on a 
bookmark and that browser window would go to the URL. 

Second, if there are more than 1 browser windows open and you double click on a 
bookmark, just search for a browser window, and the first one found opens the 
bookmark URL. 

Sorry about the multiple issue thing. I am not familiar enough with the 
components to determine which bug would go with which component. So I make my 
best guess.
But what happens if you've got something important in the window it "chooses"? 
You'll get annoyed. Anyway, I'm converting this into an RFE (request for 
enhancement) and confirming it, but don't be surprised if slamm@netscape.com 
declines to implement it. :-)

Gerv
Severity: normal → enhancement
Status: UNCONFIRMED → NEW
Ever confirmed: true
(Reporter)

Comment 8

19 years ago
If I have something important in one window, I would open another window, then 
double click on the bookmark, and Mozilla would use the newest window for my 
bookmark. This is how Netscape currently works. 

Comment 9

18 years ago
we could open the bookmark into a named window, that
way you don't lose current content, but subsequent opens
would go into the same window.  Kind-of a "bookmarks dumping
ground" in window realestate terms.
Summary: opening bookmarks from manage bookmarks should open in existing browser window → [RFE] opening bookmarks from manage bookmarks should open in existing browser window
Target Milestone: --- → M20

Comment 10

18 years ago
Reassigning 79 Bookmarks bugs to Ben.  I was told this was going to be done 
shortly about two months ago, but it clearly hasn't been.  I think that's long 
enough for all these bugs to remain assigned to nobody.

Feel free to filter all this spam into the trashcan by looking for this string 
in the message body: ducksgoquack
Assignee: slamm → ben
Netscape Nav triage team: this is not a Netscape beta stopper.
Keywords: nsbeta1-

Comment 12

18 years ago
Marking nsbeta1- bugs as future to get off the radar.
Target Milestone: --- → Future

Comment 13

17 years ago
I personaly desagree with the bug, because I don't find it natural. I guess I am
afraid of having some important pages redirected. 
The argument 'this is how netscape currently behaves' is not a good one to me as
I think we should also look for ways of improving things with Mozilla.
Nevertheless, if this gets implemented, I would like to see a 'Open in New
Window' option so I have a choice over where to display the bookmark.
Status: NEW → ASSIGNED
Paul Chen is now taking Bookmarks bugs. For your convenience, you can filter 
email notifications caused by this by searching for 'ilikegoats'.

Assignee: ben → pchen
Status: ASSIGNED → NEW

Comment 15

17 years ago
mass reassign of pchen bookmark bugs to ben
Assignee: pchen → ben

Comment 16

17 years ago
using win32 full installer build 2002012403.

um, despite the apparent disagreement with the reporter's idea, it would appear
that the reporter's intent has been met.  opening a bookmark through manage
bookmarks opens the page in the same browser window and/or tab, when only one
browser window is open.  in multiple window situations, manage bookmarks opens
bookmarks in the browser window that spawned the manage bookmarks window.

suggest resolving as either fixed or worksforme, most likely the latter.

Comment 17

17 years ago
fixed
Status: NEW → RESOLVED
Last Resolved: 17 years ago
Resolution: --- → FIXED
Product: Browser → Seamonkey
You need to log in before you can comment on or make changes to this bug.