checksetup.pl --check-modules should output a summary at the bottom

RESOLVED DUPLICATE of bug 192451

Status

()

Bugzilla
Installation & Upgrading
--
enhancement
RESOLVED DUPLICATE of bug 192451
12 years ago
11 years ago

People

(Reporter: Jacob Steenhagen, Unassigned)

Tracking

Details

(Reporter)

Description

12 years ago
It would be nice if when running checksetup.pl with the --check-modules switch and all the required modules were there that the script told you. When there are optional modules missing, it can be difficult to tell at a glance if you have everything that's required or not.

Output from my run of checksetup.pl....

[bugzilla@waldo tip]$ ./checksetup.pl --check-modules

Checking perl modules ...
Checking for       AppConfig (v1.52)   ok: found v1.56
Checking for             CGI (v2.93)   ok: found v3.15
Checking for    Data::Dumper (any)     ok: found v2.121_08
Checking for    Date::Format (v2.21)   ok: found v2.22
Checking for             DBI (v1.38)   ok: found v1.50
Checking for      File::Spec (v0.84)   ok: found v3.12
Checking for      File::Temp (any)     ok: found v0.16
Checking for        Template (v2.08)   ok: found v2.14
Checking for      Text::Wrap (v2001.0131) ok: found v2005.082401
Checking for    Mail::Mailer (v1.67)   ok: found v1.74
Checking for    MIME::Base64 (v3.01)   ok: found v3.07
Checking for    MIME::Parser (v5.406)  ok: found v5.419
Checking for        Storable (any)     ok: found v2.15

The following Perl modules are optional:
Checking for              GD (v1.20)   ok: found v2.32
Checking for     Chart::Base (v1.0)     not found
Checking for       XML::Twig (any)     ok: found v3.23
Checking for       GD::Graph (any)     ok: found v1.4307
Checking for GD::Text::Align (any)     ok: found v1.18
Checking for     PatchReader (v0.9.4)   not found
Checking for   Image::Magick (any)      not found

If you you want to see graphical bug charts (plotting historical data over
time), you should install libgd and the following Perl modules:

Chart:       /usr/bin/perl -MCPAN -e 'install "Chart::Base"'

If you want to convert BMP image attachments to PNG to conserve
disk space, you will need to install the ImageMagick application
Available from http://www.imagemagick.org, and the Image::Magick
Perl module by running (as root):

   /usr/bin/perl -MCPAN -e 'install "Image::Magick"'

If you want to see pretty HTML views of patches, you should install the
PatchReader module:
PatchReader: /usr/bin/perl -MCPAN -e 'install "PatchReader"'

Updated

12 years ago
Severity: minor → enhancement
OS: Linux → All
Hardware: PC → All

Comment 1

11 years ago
bug 192451 fixes this by making the output much clearer.

*** This bug has been marked as a duplicate of 192451 ***
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.