special html chars not shown correctly when "View Selection Source"

RESOLVED DUPLICATE of bug 236465

Status

()

RESOLVED DUPLICATE of bug 236465
13 years ago
10 years ago

People

(Reporter: martin.ereth, Unassigned)

Tracking

1.8.0 Branch
x86
Linux
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; de; rv:1.8.0.2) Gecko/20060415 SUSE/1.5.0.2-0.1 Firefox/1.5.0.2
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; de; rv:1.8.0.2) Gecko/20060415 SUSE/1.5.0.2-0.1 Firefox/1.5.0.2

The "View Selection Source" displays special html characters wrong.
For example the German ä, which is ä in html-code is displayed correctly if I view the "Page Source" but is displayed as an ä if I view the marked ä with "View Selection Source".

Not only the ä is a problem, many other, non-ASCII characters, are affected.

Reproducible: Always

Steps to Reproduce:
1. Write a short html-page which contains the html-code of the ä (&auml); or take the attached file
2. View Page Source
3. Select the character and "View Selection Source"
4. Compare result of 2. and 3.

Actual Results:  
the "View Selected Source" behaves falsely.

Expected Results:  
The two views should behave the same way. Not the ä but the corresponding html-code should be shown in "View Selection Source".
(Reporter)

Comment 1

13 years ago
Created attachment 220133 [details]
A file where you can test the behaviour of your firefox
*** This bug has been marked as a duplicate of 236465 ***

*** This bug has been marked as a duplicate of 236465 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
(Reporter)

Comment 3

13 years ago
(In reply to comment #2)
> *** This bug has been marked as a duplicate of 236465 ***
> 

Thanks for finding this duplicate. But "Give the View Selection Source window a proper name" is not the right title for this bug. 

When will this be fixed? 
Version: unspecified → 1.5.0.x Branch
Please read the details in the other bug, and in bug 190947. This will not be fixed, since it isn't a bug.
(Assignee)

Updated

10 years ago
Product: Firefox → Toolkit
You need to log in before you can comment on or make changes to this bug.