need extension flag for "requires for-pay subscription/software" and structured entry of the site/software in question

RESOLVED FIXED in 3.1

Status

addons.mozilla.org Graveyard
Developer Pages
RESOLVED FIXED
12 years ago
2 years ago

People

(Reporter: shaver, Unassigned)

Tracking

Bug Flags:
blocking-remora-launch -

Details

Some extensions we host will require a paid subscription or non-zero-cost software to use.  We should provide a standard way for developers to indicate that, and present it to the user in a consistent way.  Also, we should let users filter out "for-pay" extensions in search, RSS-updates, etc.

Updated

12 years ago
Depends on: 352560
The "externalsoftware" flag exists in Remora, and given this was reported by shaver and discussed when planning the Remora DB, I think this meets his request.
Assignee: morgamic → fligtar
Target Milestone: 2.1 → 3.0

Updated

11 years ago
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
External software is distinct from "requires payment to use", actually, though I suppose one is a subset of the other.

How about:

0 = requires no software/site membership
1 = requires free software/site membership
2 = requires for-pay software/site membership

for the external-software field?

(With constants for the enums instead, etc., natch.)
Blocks: 352560
Status: RESOLVED → REOPENED
No longer depends on: 352560
Resolution: FIXED → ---
*** Bug 336088 has been marked as a duplicate of this bug. ***
Flags: blocking-remora-launch+
This will require schema changes.
Assignee: fligtar → nobody
Status: REOPENED → NEW
Flags: blocking-remora-launch+ → blocking-remora-launch-
Target Milestone: 3.0 → 3.1
I think this is fixed well enough for now.
Status: NEW → RESOLVED
Last Resolved: 11 years ago11 years ago
Resolution: --- → FIXED
(Assignee)

Updated

2 years ago
Product: addons.mozilla.org → addons.mozilla.org Graveyard
You need to log in before you can comment on or make changes to this bug.