Can't click links inside a left-aligned table nested in a table with display:inline (can't interact with talkbacks on ynet.co.il)

VERIFIED FIXED

Status

()

defect
VERIFIED FIXED
13 years ago
13 years ago

People

(Reporter: uriber, Assigned: roc)

Tracking

({regression, testcase})

Trunk
Points:
---
Dependency tree / graph

Firefox Tracking Flags

(Not tracked)

Details

()

Attachments

(2 attachments)

Reporter

Description

13 years ago
Go to http://www.ynet.co.il/articles/0,7340,L-3240223,00.html , scroll down to
the talkback section (the numbered list on the bottom). Click one of the numbered items. In the bluish rectangle that opens up, try clicking any of the links and icons on the bottom. Notice that nothing happens.

A minimal testcase is coming up, showing that this happens to any link which is
inside a table with align="left", nested inside a table with style="display: inline;".

This regressed between 2006-01-25 and 2006-01-26, probably due to the fix for bug 317375.

Testcase coming up.
Reporter

Comment 1

13 years ago
Posted file testcase
The link in this testcase is not clickable.
In builds from before 2006-01-26, it was possible to click the top half of the text in this testcase, but not the bottom half (however, in the Ynet case, the links were fully clickable).
Reporter

Updated

13 years ago
Keywords: regression, testcase
Is this a variation of bug 334690?
Reporter

Comment 3

13 years ago
(In reply to comment #2)
> Is this a variation of bug 334690?
> 

I can't say. It regressed before 334690, and is still here after that bug was fixed.
Hardware: Macintosh → All
Posted patch fixSplinter Review
Same old story. nsTableOuterFrame is PR_FALSE for IsAbsoluteContainingBlock, but we still need to make a pseudo-stacking-context for inline tables.
Assignee: nobody → roc
Status: NEW → ASSIGNED
Attachment #220462 - Flags: superreview?(dbaron)
Attachment #220462 - Flags: review?(dbaron)
OS: Mac OS X 10.4 → All
Comment on attachment 220462 [details] [diff] [review]
fix

The pseudoStackingContext stuff basically just puts the block-float-inline layers on the inside together into one layer for the outside, right?
Attachment #220462 - Flags: superreview?(dbaron)
Attachment #220462 - Flags: superreview+
Attachment #220462 - Flags: review?(dbaron)
Attachment #220462 - Flags: review+
checked in.
Status: ASSIGNED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → FIXED
Verified FIXED using both the page testcase at http://www.ynet.co.il/articles/0,7340,L-3240223,00.html and the minimized one https://bugzilla.mozilla.org/attachment.cgi?id=220395 with build 2006-06-19-10 of SeaMonkey trunk under Windows XP.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.