Missing out-of-memory check at gfx/cairo/cairo/src/cairo-quartz-surface.c:102

RESOLVED INVALID

Status

()

Core
Graphics
RESOLVED INVALID
12 years ago
12 years ago

People

(Reporter: Denis Vlasenko, Unassigned)

Tracking

Trunk
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20060320 Firefox/1.5
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8) Gecko/20060320 Firefox/1.5

    imageData = malloc(imageDataSize);

    dataProvider =
        CGDataProviderCreateWithData(NULL, imageData, imageDataSize,
                                     ImageDataReleaseFunc);


Reproducible: Always
Should be filed against Cairo rather than Mozilla ? Over GFX:Thebes in the meantime.
Component: General → GFX: Thebes
Product: Firefox → Core
QA Contact: general → thebes
Version: unspecified → Trunk

Comment 2

12 years ago
resolving invalid since these should be filed upstream (and since they've been fixed upstream)
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → INVALID
You need to log in before you can comment on or make changes to this bug.