no way to specify queryCharset (encoding) when using addEngineWithDetails method (nsIBrowserSearchService)

RESOLVED DUPLICATE of bug 1413298

Status

()

P1
minor
Rank:
38
RESOLVED DUPLICATE of bug 1413298
13 years ago
6 months ago

People

(Reporter: kamiru68, Assigned: mkaply)

Tracking

2.0 Branch
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: [fxsearch])

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20060501 BonEcho/2.0a1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8) Gecko/20060501 BonEcho/2.0a1

Encoding Charset used to submit the data to the search engine isn`t suppoeted by addEngine or addEngineWithDetails metod.

Reproducible: Always
Status: UNCONFIRMED → NEW
Ever confirmed: true
Summary: Encoding Charset isn`t suppoeted by addEngineWithDetails metod (nsIBrowserSearchService) → no way to specify queryCharset (encoding) when using addEngineWithDetails method (nsIBrowserSearchService)
Version: unspecified → 2.0 Branch
Severity: normal → minor
Priority: -- → P3
Whiteboard: [fxsearch]

Updated

3 years ago
Rank: 38

Updated

3 years ago
Duplicate of this bug: 1105334
Severity: normal → minor
(Assignee)

Comment 3

6 months ago
P1 for WebExtension support.
Assignee: nobody → mozilla
Priority: P3 → P1
(Assignee)

Updated

6 months ago
Status: NEW → ASSIGNED
(Assignee)

Comment 4

6 months ago
We did this for WebExtensions. I had forgotten.

Really future forward dupe.
Status: ASSIGNED → RESOLVED
Last Resolved: 6 months ago
Resolution: --- → DUPLICATE
Duplicate of bug: 1413298
You need to log in before you can comment on or make changes to this bug.