Firefox won't upload pdf files from academic medical journal websites. IE will upload pdf immediately

RESOLVED WORKSFORME

Status

()

Firefox
General
RESOLVED WORKSFORME
12 years ago
11 years ago

People

(Reporter: Michael David Goldman, MD, ScD, Unassigned)

Tracking

1.5.0.x Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: CLOSEME 06/27, URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.2) Gecko/20060308 Firefox/1.5.0.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.2) Gecko/20060308 Firefox/1.5.0.2

Academic scientists are asked to review manuscripts. Each journal has its own site on the "manuscriptcentral" website. The journal CHEST and the journal American Journal of Respiratory and Critical Care Medicine send emails asking if I will review a manuscript. Firefox allows me to get into the REVIEWER CENTER of "manuscriptcentral" for both of the journals. However, when I click on the words that should provide an upload of the pdf file, Firefox hangs up and I am unable to upload. If I switch to Internet Explorer, both journals' pdf files upload quickly.

Reproducible: Always

Steps to Reproduce:
1. One must be invited by medical journal to review a manuscript
2. One gets a login and password
3. One logs into the journal's site
4. One is admitted to the REVIEWER CENTER on Firefox
5. One then attempts to click on html words to upload the pdf file

Actual Results:  
pdf file always fails to upload -- Firefox just gets hung up in the process.

Expected Results:  
pdf did not upload

If Mozilla were to contact the medical journals' IT people, (CHEST and American Journal of Respiratory and Critical Care Medicine) you might find what is blocking the upload of their material. I have already emailed both journals IT people and told them of this problem.

I wish to continue to use Firefox, because I want to avoid IE. However, I must use IE to actually upload the medical manuscript files. Then I switch back to Firefox.

Comment 1

12 years ago
Have you been able to recreate this problem on any other sites?

Does the problem still happen with recent Firefox 2 alphas and betas?  (Many things have been fixed).  You can get info on the latest nightly builds along with links to them, in the Firefox builds forum at http://forums.mozillazine.org/viewforum.php?f=23

Reporter, do you still see this problem with the latest Firefox 2? If not, can you please close this bug as WORKSFORME. Thanks!
Whiteboard: CLOSEME 06/27
Version: unspecified → 1.5.0.x Branch
No response from reporter re: comment 1 & 2 -->INCOMPLETE.
Reporter, if you still see this problem with the latest release of Firefox 2, please reopen this bug. Thanks!
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → INCOMPLETE
(Reporter)

Comment 4

11 years ago
I apologize for not noting H Kazemi's question in the past, and for not responding to S England's question with latest Firefox 2. 

I recently installed Firefox 2, and have had occasion to get on to other websites (commercial, drug company, or other websites), where one is given the opportunity to click on links which will download pdf files. In all these cases, even with Firefox 2, I still get the hang-up: you click on the link, and the indicator showing the computer is processing a download simply stops, and nothing further happens. I then get out of Firefox, and reboot the computer, and click on Internet Explorer (only for those sites from which I'm trying to download an pdf), and the process goes smoothly.

Sorry to have to tell you this, but hope the problem surfaces, or more appropriately, the mechanism to FIX the problem becomes clear.

Thank you,

Michael D. Goldman, MD, ScD
Status: RESOLVED → UNCONFIRMED
Resolution: INCOMPLETE → ---
Michael, what version of Acrobat do you have installed?
Write about:config in the URL bar, hit enter, and it should show you somewhere in there.
Michael, please reply to this bug rather than email me directly. then everything is kept in one place and other people can follow the thread.

You tell me via email you have version 7 of adobe acrobat reader. could you please try version 8.1?

Comment 7

11 years ago
Are these all dupes of each other? Or perhaps related to another meta-bug?


Bug 373621 – File upload set mime type as application/download instead of application/pdf (edit)
Bug 323462 – Sent pdf file is damaged, if sent in IE it is fine using yahoo mail (edit)
Bug 336212 – Firefox won't upload pdf files from academic medical journal websites. IE will upload pdf immediately (edit)
Bug 326821 – Mimetype output wrong on upload via php($_FILES -file_type) with FF 1.5.0.1 (edit)
Depends on: 373621
To all problem reporters:
Please read Bug 373621 Comment #5 and check mimeTypes.rdf content.
Is there multiple definitions or unexpected definition for ".pdf"?  
(Reporter)

Comment 9

11 years ago
I did recently try with Acrobat 8.1 and Firefox permitted pdf download.

Thanks
Status: UNCONFIRMED → RESOLVED
Last Resolved: 11 years ago11 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.