Can't move (drag and drop) multiple bookmarks from one folder to another

RESOLVED FIXED in mozilla1.9alpha8

Status

()

RESOLVED FIXED
13 years ago
11 years ago

People

(Reporter: franklin, Assigned: mwu)

Tracking

Trunk
mozilla1.9alpha8
x86
Linux
Points:
---
Bug Flags:
in-litmus ?

Firefox Tracking Flags

(Not tracked)

Details

Attachments

(1 attachment)

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1) Gecko/20060501 Minefield/3.0a1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1) Gecko/20060501 Minefield/3.0a1

When two or more bookmarks are selected in Places, and then dragged to a folder, nothing happens.  When I select only one of the bookarms and try to move it, it moves successfully.

Reproducible: Always

Steps to Reproduce:
1. Select multiple bookmarks
2. Drag to a folder
3. 

Actual Results:  
Nothing happens

Expected Results:  
All bookmarks should be moved to the folder
Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9a1) Gecko/20060501 Minefield/3.0a1 - Build ID: 0000000000
Confirmed.
Version: unspecified → Trunk
Status: UNCONFIRMED → NEW
Ever confirmed: true
WFM with Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060501 Minefield/3.0a1
Linux-only, then?
*** Bug 337466 has been marked as a duplicate of this bug. ***

Comment 5

11 years ago
Mozilla/5.0 (Macintosh; U; Intel Mac OS X; en-US; rv:1.9a6pre) Gecko/20070613 Minefield/3.0a6pre ID:0000000000

Confirmed on OS X. I'll look into this bug..
Assignee: nobody → cyen

Updated

11 years ago
Flags: blocking-firefox3?
I'm not seeing on windows (like Ria reported in comment #2), but I was also seeing it on mac.

although, I was seeing that when moving multiple bookmarks, only one would get moved.
Target Milestone: --- → Firefox 3 alpha6

Comment 7

11 years ago
From controller.js ( http://lxr.mozilla.org/seamonkey/source/browser/components/places/content/controller.js#1491 ), session.numDropItems is returning 1 by default on the mac, pointing to platform-specific widget code... here: http://lxr.mozilla.org/seamonkey/source/widget/src/mac/nsDragService.cpp#748

Comment 8

11 years ago
(In reply to comment #7)
> From controller.js (
> http://lxr.mozilla.org/seamonkey/source/browser/components/places/content/controller.js#1491
> ), session.numDropItems is returning 1 by default on the mac, pointing to
> platform-specific widget code... here:
> http://lxr.mozilla.org/seamonkey/source/widget/src/mac/nsDragService.cpp#748
> 

Actually - Adam pointed out that cocoa is now enabled on trunk ( http://lxr.mozilla.org/seamonkey/source/widget/src/cocoa/nsDragService.mm#525 )

Updated

11 years ago
Flags: blocking-firefox3? → blocking-firefox3+

Comment 9

11 years ago
From playing with Venkman: both nsDragService::GetNumDropItems and nsDragService::GetData are having issues on OS X. If I manually change the value of "dropCount" to be 2 or 3 using Venkman, the loop pulls the same item 2 or 3 times. If I change both the value of "dropCount" and make sure to change the id + url of the "data" on one of the iterations of the loop, both items are transferred correctly.

So - it looks like when using the cocoa widget, session.getData isn't putting the right values into nsTransferable, and getNumDropItems isn't returning the correct number of elements to drag.

From spending a bit of time with Venkman in Linux, all I could see was that dropCount is getting populated correctly there, but something's going wrong later in the function.

Comment 10

11 years ago
This bug also applies to multiple DnD in Thunderbird on Mac (e.g. dragging multiple messages from the Inbox onto the "Trash" folder in the left pane), and is almost definitely a platform bug, not a front-end one. CC'ing the appropriate people
Assignee: cyen → nobody
let's keep this bug about linux, and use bug #385116 for the mac.

for linux, christine writes:

"you simply can't drag multiple items.  on linux, dropCount is correctly returned."
Component: Places → Widget: Gtk
Flags: blocking-firefox3+
Product: Firefox → Core
QA Contact: places → gtk
Target Milestone: Firefox 3 alpha6 → mozilla1.9beta1
with mac, we confirmed this was a toolkit bug by debugging and also by testing tbird trunk.  (see bug #385116).

can someone with linux try tbird linux on trunk?
Flags: blocking1.9?

Comment 13

11 years ago
version 3.0a1pre (20070622)

Dragging of multiple e-mail messages in Thunderbird trunk on Linux works fine for me, FWIW.
Summary: Can't move multiple bookmarks from one folder to another → Can't move (drag and drop) multiple bookmarks from one folder to another
adam, thanks for trying on trunk tbird linux.

based on your comments, this is sounding more like a places bug, and not a widget bug.

for now, bringing back to places, but we could use some help in debugging this on linux.
Component: Widget: Gtk → Places
Flags: blocking1.9?
Product: Core → Firefox
QA Contact: gtk → places
Target Milestone: mozilla1.9beta1 → ---
Flags: blocking-firefox3?
Flags: blocking-firefox3? → blocking-firefox3+
(Assignee)

Comment 15

11 years ago
Created attachment 271911 [details] [diff] [review]
Check all flavors, v1

Not sure why the first flavor should always be the correct flavor when looking in a list.. so this removes that assumption. In the case of dragging bookmarks, we need the third flavor, not the first. The cocoa DnD code iterates through all the possible flavors, so I suppose this shouldn't be too wrong.

However, I'm curious as to why the TB DnD code works and the places code doesn't.
Assignee: nobody → michael.wu
Status: NEW → ASSIGNED
Attachment #271911 - Flags: superreview?
Attachment #271911 - Flags: review?
(Assignee)

Updated

11 years ago
Attachment #271911 - Flags: superreview?(roc)
Attachment #271911 - Flags: superreview?
Attachment #271911 - Flags: review?(roc)
Attachment #271911 - Flags: review?
Attachment #271911 - Flags: superreview?(roc)
Attachment #271911 - Flags: superreview+
Attachment #271911 - Flags: review?(roc)
Attachment #271911 - Flags: review+
(Assignee)

Updated

11 years ago
Assignee: michael.wu → nobody
Status: ASSIGNED → NEW
Component: Places → Widget: Gtk
Flags: blocking-firefox3+
Product: Firefox → Core
QA Contact: places → gtk
Target Milestone: --- → mozilla1.9beta1
(Assignee)

Updated

11 years ago
Assignee: nobody → michael.wu
Flags: blocking1.9?
(Assignee)

Comment 16

11 years ago
Checking in widget/src/gtk2/nsDragService.cpp;
/cvsroot/mozilla/widget/src/gtk2/nsDragService.cpp,v  <--  nsDragService.cpp
new revision: 1.18; previous revision: 1.17
done
Status: NEW → RESOLVED
Last Resolved: 11 years ago
Resolution: --- → FIXED
(Assignee)

Updated

11 years ago
Flags: blocking1.9?

Updated

11 years ago
Flags: in-litmus?
You need to log in before you can comment on or make changes to this bug.