Closed Bug 336225 Opened 15 years ago Closed 15 years ago

support unicode file name on drag and drop(D&D) on 1.8 branch

Categories

(Core :: Internationalization, defect)

1.8 Branch
x86
Windows 2000
defect
Not set
normal

Tracking

()

RESOLVED FIXED
mozilla1.8.1alpha3

People

(Reporter: masayuki, Assigned: emk)

References

Details

(Keywords: fixed1.8.1, intl)

Attachments

(1 file)

spinning out from bug 194067.

We need to support this unicode path D&D on 1.8 branch, but we need to remain the current ANSI code for Win9x support.
Target Milestone: --- → mozilla1.8.1beta1
Version: Trunk → 1.8 Branch
Attached patch 1.8 branch patchSplinter Review
I confirmed this could handle non-system codepage chars on WinXP and this could handle system codepage chars on Win98 (On Win95, drag and drop didn't work even without the patch).
Assignee: masayuki → VYV03354
Status: NEW → ASSIGNED
Attachment #220521 - Flags: superreview?(roc)
Attachment #220521 - Flags: review?(emaijala)
Attachment #220521 - Flags: approval-branch-1.8.1?(emaijala)
Comment on attachment 220521 [details] [diff] [review]
1.8 branch patch

I can't test the patch, but I'll take your word for it.
Attachment #220521 - Flags: review?(emaijala)
Attachment #220521 - Flags: review+
Attachment #220521 - Flags: approval-branch-1.8.1?(emaijala)
Attachment #220521 - Flags: approval-branch-1.8.1+
jshin:
Could you test the branch patch?
Attachment #220521 - Flags: superreview?(roc) → superreview+
(In reply to comment #3)
> Could you test the branch patch?

Doesn't work with a Hindi internet shortcut on Win2k with the default codepage set to CP949(Korean)
 

(In reply to comment #4)

> Doesn't work with a Hindi internet shortcut on Win2k with the default codepage
> set to CP949(Korean)

Ignore the above. My build didn't go through due to a compilation error. Why don't you test it yourself? 
 

(In reply to comment #5)
> Ignore the above. My build didn't go through due to a compilation error. Why
> don't you test it yourself? 
I already did the test (see comment #1). I just wanted the other's eye.
(In reply to comment #6)

> I already did the test (see comment #1). I just wanted the other's eye.

I tested it last night and it worked perfectly. Have you already landed the patch? 

 

(In reply to comment #7)
> I tested it last night and it worked perfectly. Have you already landed the
> patch? 
Not yet. branch tree has been closed for a long time :(
Please land the patch as soon as branch is open again. (I have no cvs account to commit)
-> FIXED
Status: ASSIGNED → RESOLVED
Closed: 15 years ago
Keywords: fixed1.8.1
Resolution: --- → FIXED
Target Milestone: mozilla1.8.1beta1 → mozilla1.8.1alpha3
Depends on: 416344
You need to log in before you can comment on or make changes to this bug.