Deleting a profile deletes the whole Windows profile

RESOLVED DUPLICATE of bug 302087

Status

()

--
critical
RESOLVED DUPLICATE of bug 302087
13 years ago
13 years ago

People

(Reporter: wolfgang.killinger, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.0.2) Gecko/20060308 Firefox/1.5.0.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.0.2) Gecko/20060308 Firefox/1.5.0.2

I could not start Firefox (now Window is displayed), therefore I created a new profile. I had to do this several times and therefore had serveral profile folders in the Windows profile folder (e.g. C:\Documents and Settings\kiw8fe\ff_profile). When I choose to delete a profile, Firefox tried to delete the complete Windows profile, i.e. delete every file and folder in C:\Documents and Settings\kiw8fe! This corrupted my PC and it was very tiresome to restore it.

I consider this as a high level error. I very much propageted the use of Firefox in my company, but this is a serious flaw, which objects against use in a big company with more than 30.000 Windows clients. If users can erraneously cause such havoc on their systems, this can not be handled by our internal support division properly.

I will not try to reproduce it , as it takes a lot of work to undo the damage.

Reproducible: Didn't try

Steps to Reproduce:
1.Create custom profile with folder for profile data below Windows profile folder.
2.Start Firefox with option -p
3.Select the custom profile and press delete
4.Firefox tries to delete the complete Windows profile folder.

Actual Results:  
I could not start my PC any more, because the Windows profile data (and for many other applications to) were lost!!!

Expected Results:  
Delete only the folder, which contains data for the selected Firefox profile.

*** This bug has been marked as a duplicate of 302087 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.