ChatZilla not receiving or sending messages/commands

RESOLVED WORKSFORME

Status

--
major
RESOLVED WORKSFORME
13 years ago
13 years ago

People

(Reporter: orlandoarias, Assigned: rginda)

Tracking

Trunk
x86
Windows XP

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.2) Gecko/20060308 Firefox/1.5.0.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.2) Gecko/20060308 Firefox/1.5.0.2

ChatZilla stops sending or receiving messages/commands after idling for a while in the channel. ChatZilla is still connected to the network, it just does not send/recieve anything. CPU time remains normal.
I have not tested it in other networks yet, but the issue appears in the rizon network.
Cheers.

Reproducible: Always

Steps to Reproduce:
1. Idle in a channel.
Actual Results:  
Chatzilla stops receiving or sending messages/commands.

Expected Results:  
Chatzilla should send/receive messages.

bug occurs in a vanilla install of Firefox 1.5.0.2 with chatzilla.

Comment 1

13 years ago
Which version of ChatZilla are you using?
Can you check if packages are actually sent to ChatZilla using a packet listener such as Ethereal?
Can you try to use debugmode to see if events come in at all?
What's the length of the event queue? ("/eval client.eventPump.queue.length" as well as "/eval client.eventPump.bulkQueue.length")

More info please :-)
(Reporter)

Comment 2

13 years ago
Both client.eventPump.bulkQueue.length and client.eventPump.queue.length return 0 when evaluated. However, the bot I wrote is receives messages sent by other users.

Using Chatzilla 0.9.73 [Firefox 1.5.0.3/2006042618]
Ignore list is empty.
Thanks and Cheers,
Orlando Arias.

Comment 3

13 years ago
OK, so can you try debugmode or using Ethereal to verify Necko (network libraries) and ChatZilla itself actually get these messages? Or give more precise instructions, because I spend 80% of my time in ChatZilla idling and have never had the same problems. What channel is this in? What network? Who's sending these messages? How long does it take until ChatZilla starts behaving weirdly?

Comment 4

13 years ago
Been a month, no further info -> WFM.

Please reopen this bug if you can still reproduce and have more info than is already in this bug - I can't reproduce it as it is.
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 5

13 years ago
After upgrading firefox to version 1.5.0.4 the bug has dissapeared. Thank you.
You need to log in before you can comment on or make changes to this bug.