Mark a message as junk moves the lines in the message window as if the slider bar was moved

RESOLVED DUPLICATE of bug 209748

Status

Thunderbird
Mail Window Front End
RESOLVED DUPLICATE of bug 209748
12 years ago
12 years ago

People

(Reporter: Karl Behler, Assigned: Scott MacGregor)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.8.0.1) Gecko/20060206 Firefox/1.5.0.1
Build Identifier: Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.8.0.1) Gecko/20060206 Firefox/1.5.0.1

Having a couple of hundred mails (mostly junk) after a weekend I'm doing a quick browse through it using the slider. Everytime I mark a message as junk the particular message is marked and deleted (as requested) but immediately after the at action the display jumps back up to a damn other place in the message list.
So everytime having marked a message as junk one has to reposition the display to proceed viewing messages. Selecting the message first and then marking it as
junk helps, but is not what one really intends to do.

This issue seems to be connected with the filed issues 331013 and 325771.

Reproducible: Always

Steps to Reproduce:
1.Just have a couple of windows full of mails. And start at the beginning.
2.Move down the list by using the slider on the right. Selected message vanishes out of the top of the window.
3.Down at third or forth windows full of messages mark one not already selected message as junk. As a result the list window not only shows the junk message deleted and marked but also jumps up an arbitrary number of list items.



Expected Results:  
Marking a message as junk should not move the list display in any way.

Marking the message as "not junk" does not show the described behaviour.

Comment 1

12 years ago
I believe this is fixed on the trunk and the 1.8.1 nightly branch builds, so the fix will be in 2.0. (but not 1.5.0.x)

*** This bug has been marked as a duplicate of 209748 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.