Closed Bug 336249 Opened 14 years ago Closed 11 years ago

Firefox hangs on a website with a large number of nested and absolutely positioned <div>'s

Categories

(Core :: Layout: Positioned, defect, critical)

x86
Windows 2000
defect
Not set
critical

Tracking

()

RESOLVED DUPLICATE of bug 317561

People

(Reporter: jefdriesen, Unassigned)

References

()

Details

(Keywords: hang, testcase)

Attachments

(1 file)

User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.0.2) Gecko/20060308 Firefox/1.5.0.2
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.0.2) Gecko/20060308 Firefox/1.5.0.2

When I view one of the URLs below, the browser becomes completely unresponsive and I have to kill the process with the taskmanager.

http://www.digischool.nl/bi/onderwaterbiologie/html/duikloka/zeeland/duikzeel.htm
http://www.anemoon.org/duiklocaties/html/duiklokatie/zeeland/zeeland.htm

I reported the problem in the mozilla.support.firefox and mozilla.dev.apps.firefox newsgroups and the problem was confirmed by many other users of Firefox 1.5.0.x. Older versions (FF 1.0.7 and other Gecko 1.7 browsers) do not have this problem.

One poster suggested that the problem is caused by a number unclosed <div> tags (which are therefor treated as nested). These <div> tags are also positioned absolutely with css.

"Reason is that there is a number of DIV tags like <div id="img1"> in this web page and all of them aren't closed. As the result the browser treats them as if they were nested. I think I've seen code in the HTML parser that limits nesting depth to handle malformed code like this. Unfortunately here it isn't enough - each of these divs is positioned absolutely and the layout engine seems to have a hard time calculating their actual positions."

Properly closing all <div>'s (and keeping the nested layout) does not solve the issue. If I close all <div>'s properly after the <img> tag (e.g. a "flat" layout), FF does not hang anymore. But obviously the <div>'s are not positioned correctly.

Another poster suggested the possible source of the problem:

"Looking through some older builds, the change in behavior happens between 2004-11-26-07 and 2004-11-27-07.  That would correspond to bug 201897 landing, most likely."

Reproducible: Always
Keywords: hang, testcase
Sounds like bug 317561.
Component: General → Layout: R & A Pos
Depends on: 317561
Product: Firefox → Core
QA Contact: general → layout.r-and-a-pos
Version: unspecified → Trunk
(In reply to comment #2)
> Sounds like bug 317561.

It's the same cause, and both are fixed by the reflow refactoring.
Status: UNCONFIRMED → RESOLVED
Closed: 11 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 317561
You need to log in before you can comment on or make changes to this bug.