Closed Bug 336267 Opened 14 years ago Closed 5 months ago

If software update is 'ask' after an update has been downloaded, the update should be disabled or asked

Categories

(Toolkit :: Application Update, defect, P3)

defect

Tracking

()

VERIFIED FIXED
mozilla69
Tracking Status
firefox69 --- verified

People

(Reporter: benjamin, Assigned: rstrong)

References

(Depends on 1 open bug, Blocks 1 open bug)

Details

Attachments

(3 files)

Once an update has been downloaded, there is no way to disable installing the update. If a user goes into preferences and disables software update after the update has been downloaded, or sets the preference to "ask", we should disable or ask about the already-downloaded update.
Component: Extension/Theme Manager → Software Update
QA Contact: extension.manager → software.update
Hmmm... I added this for the installs view for pending installs and chose to remove it just to simplify the changes I was making. It would be simple enough to add back in.
Doh... nevermind - thought this was still an EM bug.
(In reply to comment #0)
> Once an update has been downloaded, there is no way to disable installing the
> update. If a user goes into preferences and disables software update after the
> update has been downloaded, or sets the preference to "ask", we should disable
> or ask about the already-downloaded update.
> 

I use Windows XP Home Edition SP2, and I've had this happen with the latest
versions of Thunderbird & Firefox.
I used Task Manager (CTRL+ALT+DEL) to end task on both programs, browsed to
the program directories (C:/Program Files/Mozilla WHATEVER), renamed
thunderbird.exe or firefox.exe to thunderbird.mybackup & firefox.mybackup,
and then renamed firefox.mozbackup & thunderbird.mozbackup to firefox.exe
and thunderbird.exe.
When I double clicked the .exes, the updates completed successfully.
First, no one's going to know that flipping the pref after the fact will have this behavior. The dialog's already told them we're going to go ahead and do it, they're already pissed off.

Second, if we take away the dialog as Beltzner proposes then the user will not know an update was available and will not have a chance to go flip this pref even if they know about the magic feature proposed here.

I don't see what problem this bug is solving.
This is primarily solving the problem of QAing older builds: when you install the build it will update immediately, before you have the chance to disable update.
CCing self...

ignore this
& &amp & _&_;
ignore this
(In reply to comment #5 by Dan Veditz)
> ... no one's going to know that flipping the pref after the fact will have
> this behavior. The dialog's already told them we're going to go ahead and do
> it, they're already **** off.

Why don't we just change the words in the pref "Ask me what to do" to "Ask me
when to install, and ask me again before installation"? It's ugly but it's a
good quick fix to stop us from losing the vocal minority who hate auto-update
and hate that it provides no "Don't Update" option.
Product: Firefox → Toolkit
Duplicate of this bug: 465046
Updating summary to reflect the current implementation where disabling within Firefox is no longer an option.
Summary: If software update is disabled or "ask" after an update has been downloaded, the update should be disabled or asked → If software update is 'ask' after an update has been downloaded, the update should be disabled or asked
Priority: -- → P3

Could we please resolve this bug, Because of default settings it is impossible
as OP said to prevent an initial update via the user interface. Future updates
will be prevent yes, but if you install an old version it will be upgraded to
the current version before disabling updates. Here is a workaround:

  1. when installing, uncheck "Launch Firefox now"

  2. delete

    C:\Program Files\Mozilla Firefox\updater.exe
    

Note that you will still see the message "Restart to update Firefox", but if you
restart the old version will remain. Or an alternative workaround:

  1. when installing, uncheck "Launch Firefox now"

  2. navigate to

    C:\Program Files\Mozilla Firefox\defaults\pref\channel-prefs.js
    
  3. add this line

    pref('app.update.auto', false);
    
Flags: needinfo?(robert.strong.bugs)
Flags: needinfo?(robert.strong.bugs)
Assignee: nobody → robert.strong.bugs
Status: NEW → ASSIGNED
Attached image screenshot.png

Hi Bram, when changing the update setting from "Automatically install updates (recommended)" to "Check for updates but let you choose to install them" if there is an existing update in progress there is no option to discard it. This is especially problematic when someone downloads an older build to test something since the update could already be in progress before changing this setting and the older build will end up being updated out from under them.

Can I get your feedback on whether showing this dialog when the user changes the setting to "Check for updates but let you choose to install them" AND there is an update in progress? Also, what strings you would like if you are ok with this?

Attachment #9063714 - Flags: ui-review?(bram)
Flags: needinfo?(mheubusch)

I recommend keeping the title of the modal as is, changing the instructional copy to : An update to <short name> is in progress. Do you want to install this update?
And then change the left button to: Install

Flags: needinfo?(mheubusch)
Attached image Recommended strings.png

Hi Michelle, I think this will cause some confusion since clicking Install won't actually install the update and there will also be users that will think clicking Install will restart the browser since that is the normal Install flow for an update. It is also not always possible to Install at this point since the update could be in the download phase of the update process.

With the above in mind, could Install be removed from the text or have the text be something along the lines of install this update when it is ready?

Flags: needinfo?(mheubusch)

I received the following strings from Michelle so clearing the needinfo and thanks!

update-in-progress-title = Update In Progress
update-in-progress-message = Do you want Firefox to continue with this update?
update-in-progress-ok-button = &Continue
update-in-progress-cancel-button = &Discard

Flags: needinfo?(mheubusch)
Pushed by rstrong@mozilla.com:
https://hg.mozilla.org/integration/autoland/rev/6e27e86c9ab0
When disabling automatic updating and there is an update in progress ask the user if they want to cancel the update. r=flod,bytesized
Status: ASSIGNED → RESOLVED
Closed: 5 months ago
Resolution: --- → FIXED
Target Milestone: --- → mozilla69

@ Robert Strong (Robert they/them) [:rstrong] - Any chances to land it also in Firefox 68?

Status: RESOLVED → VERIFIED
QA Contact: Virtual

(In reply to Virtual_ManPL [:Virtual] - (please needinfo? me - so I will see your comment/reply/question/etc.) from comment #25)

@ Robert Strong (Robert they/them) [:rstrong] - Any chances to land it also in Firefox 68?

Doubtful since strings were needed.

Flags: needinfo?(robert.strong.bugs)
Comment on attachment 9063714 [details]
screenshot.png

Looks great, Robert!

The only recommendation I would make is to switch the icon from a question mark to a green upwards arrow – the same icon we use to indicate that an update is available/ready.

Otherwise, good to go.
Attachment #9063714 - Flags: ui-review+

(In reply to Bram Pitoyo [:bram] from comment #32)

Comment on attachment 9063714 [details]
screenshot.png

Looks great, Robert!

The only recommendation I would make is to switch the icon from a question
mark to a green upwards arrow – the same icon we use to indicate that an
update is available/ready.

Otherwise, good to go.

Hi Bram, Michelle provided UX feedback and this has already landed. I've got a couple of other bugs that are high priority at the moment but I'll try to circle back around to this sometime in the future. Thanks!

You need to log in before you can comment on or make changes to this bug.