In first session, delete to Trash not placing messages in Trash folder.

VERIFIED WORKSFORME

Status

MailNews Core
Backend
P3
major
VERIFIED WORKSFORME
18 years ago
10 years ago

People

(Reporter: laurel, Assigned: Bienvenu)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

18 years ago
Using 2000-03-28-09m15 commercial builds NT 4.0 and linux rh6.0
Haven't been able to get mac installed yet 

Deleting IMAP messages (set to Move to Trash folder) is behaving erratically.  I
am able to delete a message or two from the Inbox or other IMAP folder and see
it is removed and appears in the trash folder.  After a couple, the message is
removed from the current folder but doesn't appear in the trash folder.

I am having similar problems with Empty Trash on IMAP.  Sometimes it works and
sometimes it doesn't.
(Reporter)

Updated

18 years ago
QA Contact: lchiang → laurel

Comment 1

18 years ago
see bug 23447

Comment 2

18 years ago
cc'ing bienvenu. M15....
Status: NEW → ASSIGNED
Target Milestone: --- → M15
(Assignee)

Comment 3

18 years ago
I'll take this.
Assignee: jefft → bienvenu
Status: ASSIGNED → NEW
(Assignee)

Comment 4

18 years ago
this works for me now. Please re-open if you can reproduce this problem.
Status: NEW → RESOLVED
Last Resolved: 18 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 5

18 years ago
David, this is still not working consistently.  I've tried m15 and m16. I tried
on Esther's profile as well as some of mine.  Here's what I'm seeing... I am
switching between Inbox and Trash to view whether each delete makes it to trash.

1.  Login to IMAP account where delete is set to Move to Trash folder.
2.  Delete a message from the Inbox. It removes from the Inbox.
3.  Open the trash folder, it appears there.
4.  Go back to the Inbox. Previously deleted message is indeed still gone (no
disappearing/reappearing kind of thing).  Delete another message. Message is
removed from the thread pane.
5.  Go to the trash folder.  Message which was just deleted from inbox is not
there.

It seems that messages deleted before you open the trash folder do wind up
displaying in the trash.  After opening the trash folder then going back to
Inbox and deleting another will not show up in the trash folder.

Status: RESOLVED → REOPENED
Resolution: WORKSFORME → ---
(Reporter)

Comment 6

18 years ago
Cleared the target milestone.  I don't think this is immediately urgent.
Target Milestone: M15 → ---
(Assignee)

Comment 7

18 years ago
the above steps do indeed "work for me".

I don't know what's different about your setup.

(Assignee)

Comment 8

18 years ago
one thing that can be confusing is that unless you're sorted by order of 
arrival in the trash, you may not see deleted messages depending on what the 
original date of the deleted message is.
(Reporter)

Comment 9

18 years ago
OK, augh. I tried on brand new profiles and it works. Now I'll try to figure out
why the migrated profiles don't work...Not sure whether I should (re)close this
or not.
(Assignee)

Comment 10

18 years ago
No, don't re-close it - I just want to know how to recreate it :-)
(Reporter)

Comment 11

18 years ago
OK, here's what I'm seeing today using yesterday's m16 build, NT 4.0:
It appears that with either migrated or new profiles, delete to trash doesn't
work consistently to put deleted item into trash folder until exit and restart. 

Note:  yesterday I was seeing the inconsistency last a few sessions when using a
migrated account where it migrated as Mark as Deleted, then I changed to Move to
Trash. Once

Migrated:
1.  4.7 profile had Move to Trash set, no items in trash folder (so you couldn't
accuse me of not seeing the items show in the trash folder later).
2.  Migrated profile. Went to mail, logged in, got messages.
3.  Deleted a message from the inbox, it removed from inbox thread pane.
4.  Went to trash folder, message was there.
5.  Went back to inbox, deleted another message. It removed from thread pane.
6.  Went to trash folder, message was not there.
7.  Exited and relaunched.  Did same scenario, seemed to work correctly.

Migrated:
1.  4.7 profile had Mark as Deleted set, no items in trash folder (so you
couldn't accuse me of not seeing the items show in the trash folder later).
2. in 4.7 compacted inbox.
3.  Migrated profile. 
4.  Edited server account settings to change to Move to Trash folder. Exited
seamonkey.
5.  Launched seamonkey, went to mail, logged in, got messages.
3.  Deleted a message from the inbox, it removed from inbox thread pane.
4.  Went to trash folder, message was there.
5.  Went back to inbox, deleted another message. It removed from thread pane.
6.  Went to trash folder, message was not there.
7.  Exited and relaunched.  Did same scenario, seemed to work correctly.

New Profile:
1.  Set up new profile, filled in IMAP account info in wizard. (Default setting
is Move to Trash).
2.  Logged into account, got messages.
3.  Deleted a message from the inbox, it removed from inbox thread pane.
4.  Went to trash folder, message was there.
5.  Went back to inbox, deleted another message. It removed from thread pane.
6.  Went to trash folder, message was not there.
7.  Exited and relaunched.  Did same scenario, seemed to work correctly.

(Assignee)

Comment 12

18 years ago
Changing summary. I checked in a fix for a different bug that may be related to 
this - I can't tell for sure since I was not able to reproduce this one. Could 
you try just ONE of the scenarios that didn't work before and see if it works 
now? (I don't want to make you spend a lot of time on the faint chance that this 
may be fixed...)
Summary: Delete to Trash not placing messages in Trash folder. → In first session, delete to Trash not placing messages in Trash folder.
(Reporter)

Comment 13

18 years ago
Will do on Tuesday. Am taking the day off Monday.
(Reporter)

Comment 14

18 years ago
Working OK in first session for migrated or new profiles.
Using apr18 m16 commercial build.
Status: REOPENED → RESOLVED
Last Resolved: 18 years ago18 years ago
Resolution: --- → WORKSFORME
(Reporter)

Comment 15

18 years ago
Marking verified.
Status: RESOLVED → VERIFIED
Product: MailNews → Core
Product: Core → MailNews Core
You need to log in before you can comment on or make changes to this bug.