various preferences etc. dialogue boxes' contents don't fit

RESOLVED INVALID

Status

()

Firefox
Preferences
RESOLVED INVALID
12 years ago
8 years ago

People

(Reporter: Ian Jackson, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Whiteboard: DUPEME or CLOSEME)

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.1) Gecko/20060413 Ubuntu/dapper Firefox/1.5.0.1
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.1) Gecko/20060413 Ubuntu/dapper Firefox/1.5.0.1

In 
 https://launchpad.net/distros/ubuntu/+source/firefox/+bug/36985
 https://launchpad.net/distros/ubuntu/+source/firefox/+bug/26225
Ubuntu users reported that various of the dialogues and windows accessible from Edit / Preferences were too small for their contents.  I was able to reproduce this with a fresh profile from the Ubuntu build.

Note that Ubuntu's firefox generally uses pango for most of its font rendering, which might have an effect on the overall layout.

I have gone through all of the dialogue boxes which were insufficiently large and changed the sizes in our version, and will attach the corresponding patch to this report after I have filed it.

However, the system strikes me as fragile.  Some of the dialogue boxes have sizes in ems, at least, rather than pixels, but even then changes to the content seem not to be reliably reflected in dialogue size changes.  Surely there should be some kind of automatic sizing mechanism which would avoid these kind of problems ?

Reproducible: Always

Steps to Reproduce:
For example, in Ubuntu 1.5.dfsg+1.5.0.2-0ubuntu1, select
 Edit / Preferences ... / Connection Settings ...
and observe that the RHS of the dialogue contents are off the RHS of the dialogue box.
(Reporter)

Comment 1

12 years ago
Created attachment 220635 [details] [diff] [review]
patch to increase sizes of various dialogues

Patch as I said I'd attach.  Note that I consider this kind of change to be a workaround rather than an actual fix, as discussed.
Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.9a1) Gecko/20060502 Minefield/3.0a1 - Build ID: 0000000000
WFM, and I'm built with Pango enabled. This might be a Ubuntu-specific bug.

Updated

11 years ago
Whiteboard: DUPEME or CLOSEME
https://bugs.launchpad.net/ubuntu/+source/firefox/+bug/43528
comment 6 and 8 seems to indicate this was a Ubuntu theme problem.

-> INVALID
Status: UNCONFIRMED → RESOLVED
Last Resolved: 9 years ago
Resolution: --- → INVALID

Updated

8 years ago
You need to log in before you can comment on or make changes to this bug.