font settings are being applied incorrectly to tabs

RESOLVED WORKSFORME

Status

()

Firefox
General
--
minor
RESOLVED WORKSFORME
12 years ago
12 years ago

People

(Reporter: David Miller, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060503 Minefield/3.0a1
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060503 Minefield/3.0a1

font changes which are applied to FireFox do not apply to every tab.  They only apply to the first tab - the others contain visual errors.

Reproducible: Always

Steps to Reproduce:
1. open two tabs, one to bugzilla.mozilla.org and the other to cnn.com
2. change the font settings with the cnn.com tab open and change the font size to 72 point
3. refresh the cnn.com browser.

Actual Results:  
The 72 point font is applied to the bugzilla.mozilla.org tab while the cnn.com one retains it's previous setting.  However, if you use your scroll-wheel or arrow keys to navigate down the website (cnn.com) the site will move very slowly, as if the setting were at 72 point.

Expected Results:  
The font should be applied to all tabs.
Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060503 Minefield/3.0a1
Yes, at least half of the pages dont react at all to changed font-size.
Only if you set a minimum size (24 at the most) it reacts.
I see the same behaviour in 1.0.7 and 1.5.0.2.
I guess you need to do this with a userContent.css if you really need big letters.
(Reporter)

Comment 2

12 years ago
> I guess you need to do this with a userContent.css if you really need big
> letters.

I don't, but I think if FireFox wants to make a turn towards having more "accessibility" options, being able to do this for users with bad eye sight wouldn't be such a bad idea :-)

(Reporter)

Comment 3

12 years ago
SteveE just mentioned something to me that's kind of interesting.  Maybe reflow will take care of this?
You mean the reflow refactoring branch?  Unlikely to be related.
Are you sure this is related to tabs rather than to the particular site?
(Reporter)

Comment 6

12 years ago
(In reply to comment #5)
> Are you sure this is related to tabs rather than to the particular site?
> 

Yes, it is most definitely not just a side specific issue.  I tried this with Fark.com and CNN.com and Mozilla.org open at the same time and tried it in each tab.  In each instance, the primary tab (Mozilla.org) is the one which got the settings applied.  I will try to come up with a creative way to screen-cap this and attach it.  Although I'm low on ideas for how I would do that since it's related to tabs :-)
(Reporter)

Comment 7

12 years ago
Actually, you appear to be right about that.  It is a site issue but only affects CNN and MSNBC.  I wonder why?
(Reporter)

Updated

12 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → FIXED

Updated

12 years ago
Status: RESOLVED → UNCONFIRMED
Resolution: FIXED → ---

Updated

12 years ago
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago12 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.