Closed Bug 336584 Opened 15 years ago Closed 4 years ago

Not possible to drop anything on the tree-item anymore with this testcase

Categories

(Core :: Layout, defect)

x86
Windows XP
defect
Not set
normal

Tracking

()

RESOLVED WONTFIX

People

(Reporter: martijn.martijn, Unassigned)

References

Details

(Keywords: regression)

The testcase comes from bug 281246.

You need this file:
https://bugzilla.mozilla.org/attachment.cgi?id=200597
and this file:
https://bugzilla.mozilla.org/attachment.cgi?id=203743

Download them both to your desktop.
You should be able to drag the button to the tree-item. Upon dropping it, Mozilla crashes (which is bug 281246).

In current trunk builds, I'm not able to drop the button anymore on the tree-item.
This regressed between 2006-04-09 and 2006-04-10:
http://bonsai.mozilla.org/cvsquery.cgi?treeid=default&module=all&branch=HEAD&branchtype=match&dir=&file=&filetype=match&who=&whotype=match&sortby=Date&hours=2&date=explicit&mindate=2006-04-09+06&maxdate=2006-04-10+12&cvsroot=%2Fcvsroot
Not sure which bug could be the cause, maybe a regression from bug 328926?
I can't get these testcases to load the tree contents. I can get
https://bugzilla.mozilla.org/attachment.cgi?id=201457 to load the tree contents once I've unzipped it locally, but then I can't drag the button at all.
I'm not sure what you mean with 'can't get to load the tree contents'.
You need to download the two files I mentioned in comment0 locally and then you should be able to drag the button.
What currently doesn't work anymore is it to drop it on the tree-item.
You need to download the testcase to your desktop because of the enhanced privileges, I use.
I'm not sure, but I think the zipped testcase doesn't have these enhanced privileges, so you probably should run it as chrome.
I mean that even if I rename the RDF file to ddtest.rdf, my tree doesn't have any rows.

I guess I'll retry the zipped testcase
Sorry, Robert, I blamed the wrong bug. It's still strange, though, that you're not getting any rows. Are you testing in a special debug build, or something?
I can image this to not work, but I would at least expect this to work/not work consistently across platforms (assuming you're on Linux, Robert).

This regressed with bug 330494. I noticed the warnings about the deprecated usage of preventBubble, but I ignored them. But I guess that was the cause of the problem. Now, I'm using stopPropagation for the testcase in bug 281246, https://bugzilla.mozilla.org/attachment.cgi?id=221065 ) and it works again.

I think this is wrong of Mozilla, though. Mozilla should throw a js error (in which case, I would have listened), or the preventBubble method should still work like it used to, but then I would get the js warnings in the error console.
Blocks: 330494
Hmm, I wonder if this could be WONTFIXed or perhaps for Moz2 preventBubble and preventCapture could be just removed.
Is this still a concern? If yes, please provide updated test case and I will check Release & Nightly.
Flags: needinfo?(bugs)
Haven't heard anyone complaining about this kind of XUL issue. Better to close.
Status: NEW → RESOLVED
Closed: 4 years ago
Flags: needinfo?(bugs)
Resolution: --- → WONTFIX
You need to log in before you can comment on or make changes to this bug.