crash in DisposeUnicodeToTextInfo running i18n smoketest pages

VERIFIED INVALID

Status

()

defect
P3
critical
VERIFIED INVALID
20 years ago
20 years ago

People

(Reporter: cbegle, Assigned: ftang)

Tracking

({crash})

Trunk
PowerPC
Mac System 8.6
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

()

so like i keep crashing  in the same place when i run the i18n smoketests. i
can't reproduce it with any one page.  here's what i usually do.
1. go to the url above.
2. skip down to the i18n section.
3. open each i18n link in a new window (control-click each link, open in new window)


Calling chain using A6/R1 links
  Back chain  ISA  Caller
  00000000    PPC  1B8C6EF8
  0A8B2380    PPC  1B8B61E0  main+00188
  0A8B22F0    PPC  1B8B5B0C  main1(int, char**, nsISplashScreen*)+00624
  0A8B2200    PPC  1B558390  nsAppShellService::Run()+58390
  0A8B21C0    PPC  1B526F40  nsAppShell::Run()+00038
  0A8B2170    PPC  1B527660  nsMacMessagePump::DoMessagePump()+0003C
  0A8B2120    PPC  1B527968  nsMacMessagePump::DispatchEvent(int,
EventRecord*)+00174
  0A8B20D0    PPC  1BDF18D4  Repeater::DoRepeaters(const EventRecord&)+00030
  0A8B2090    PPC  1B50C354  nsMacNSPREventQueueHandler::RepeatAction(const
EventRecord&)+000
0C
  0A8B2050    PPC  1B50C46C  nsMacNSPREventQueueHandler::ProcessPLEventQueue()+000B0
  0A8B1FE0    PPC  1B37236C  nsEventQueueImpl::ProcessPendingEvents()+00038
  0A8B1F80    PPC  1B3CC7A4  PL_ProcessPendingEvents+0004C
  0A8B1F40    PPC  1B3CC88C  PL_HandleEvent+00020
  0A8B1F00    PPC  1B2540FC  nsStreamListenerEvent::HandlePLEvent(PLEvent*)+540FC
  0A8B1EC0    PPC  1B254F50  nsOnStopRequestEvent::HandleEvent()+54F50
  0A8B1E70    PPC  1B26E114  nsInputStreamChannel::OnStopRequest(nsIChannel*,
nsISupports*, u
nsigned int, const unsigned short*)+6E114
  0A8B1E20    PPC  1B26C198  nsLoadGroup::RemoveChannel(nsIChannel*,
nsISupports*, unsigned i
nt, const unsigned short*)+6C198
  0A8B1DA0    PPC  1B90F090  nsDocLoaderImpl::OnStopRequest(nsIChannel*,
nsISupports*, unsign
ed int, const unsigned short*)+0F090
  0A8B1D50    PPC  1B90F1CC  nsDocLoaderImpl::DocLoaderIsEmpty(unsigned int)+0F1CC
  0A8B1CF0    PPC  1B90F2A4  nsDocLoaderImpl::DocLoaderIsEmpty(unsigned int)+0F2A4
  0A8B1C90    PPC  1B90F470
nsDocLoaderImpl::FireOnEndDocumentLoad(nsDocLoaderImpl*, nsIChan
nel*, unsigned int)+0F470
  0A8B1C30    PPC  1B644A58  nsWebShell::OnEndDocumentLoad(nsIDocumentLoader*,
nsIChannel*, u
nsigned int)+003F0
  0A8B1540    PPC  1B552B10
nsWebShellWindow::OnEndDocumentLoad(nsIDocumentLoader*, nsIChann
el*, unsigned int)+52B10
  0A8B13D0    PPC  1B551E20  nsWebShellWindow::DynamicLoadMenus(nsIDOMDocument*,
nsIWidget*)+
51E20
  0A8B1230    PPC  1B518E28  nsMenuBar::MenuConstruct(const nsMenuEvent&,
nsIWidget*, void*,
void*)+00590
  0A8B0EC0    PPC  1B5133A4  nsMenu::SetLabel(const nsString&)+00164
  0A8B0DC0    PPC  1B515C18  nsMenu::NSStringNewMenu(short, nsString&)+000AC
  0A8B0C30    PPC  0025E170  ConvertFromUnicodeToScriptCodeRun+000DC
  0A8B0B90    PPC  0025DE24  ConvertFromUnicodeToTextRun+00064
x

x

PowerPC access exception at 00258D04 DisposeUnicodeToTextInfo+000F4
add severity, crash keyword.  this is onthe mac, system 8.6, with tip builds
from 2000032808.
Severity: normal → critical
Keywords: crash
OS: Mac System 8.5 → Mac System 8.6
(from netherland... )  I will look at this after back to mountain view. Is this 
is a new bug ? Will it crash the beta1 branch ?
Status: NEW → ASSIGNED
Mark it M15
Target Milestone: --- → M15
cannot reproduce now because I cannot do control-clkck on link now.
since the command-click is not disable on mac anyway, this crash won't be able 
to be surface, mark it M16. Fix it after the Mac control-click enabled. I have 
talk to pinkerton and he said there are no one currently working on fixing the 
command-click issue now. So I think it is ok for me to mark it as M16.
Target Milestone: M15 → M16
Is there a bug for the Mac control-click?
This bug should depend upon that one, unless someone can come up with another
way to reproduce this crash.
I can no longer reproduce this crash. Mark it INVALID. Please reopen if you can 
still crash it. I think the bug got fixed by the context menu code.
Status: ASSIGNED → RESOLVED
Closed: 20 years ago
Resolution: --- → INVALID
Verified as Invalid.
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.