Bookmark menu should remain displayed when performing actions on it

RESOLVED DUPLICATE of bug 195031

Status

()

--
enhancement
RESOLVED DUPLICATE of bug 195031
13 years ago
13 years ago

People

(Reporter: bikrrr, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.3) Gecko/20060426 Firefox/1.5.0.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.3) Gecko/20060426 Firefox/1.5.0.3

The bookmark menu (whether it be the Bookmarks menu, or a Bookmark button menu) should remain visible after an operation is performed on it. Including but not limited to: 
- Sort by Name
- Delete
- New Separator
- New Folder 
- New Bookmark

This is mainly a usability enhancement, as it is probably working as designed, but the design is suboptimal. 

There are two main reasons for this:
1) User feedback should be provided so that the user can confirm the operation was successful. When you right-click on an item in a bookmark menu then choose Delete and then the whole menu dissappears, it does not instill confidence that the action was successful.
2) When a user is in "bookmark management" mode, they will most likely perform OTHER bookmark management tasks in the same session. So if a user right-clicks in a bookmark menu to create a folder, they will most likely want to move bookmarks into that new folder. When the menu disappears, it makes it more cumbersome to continue working on bookmark organization.

Reproducible: Always

Steps to Reproduce:
1. Click the Bookmarks menu
2. Right-click somewhere below the first separator, in the user's bookmarks section.
3. Click on New Folder...
4. Click OK to accept the default name
Actual Results:  
Bookmarks menu closes/disappears.

Expected Results:  
Bookmarks menu should remain visible.

The current design forces the user to click more than necessary when performing bookmark maintenance via the right-click menu. Also, the importance of user feedback can't be overstated. Displaying the menu after the user clicks a function is a great way to provide visible feedback that the action was taken and allow for further bookmark management tasks.

*** This bug has been marked as a duplicate of 195031 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.