Advanced Searching: filtering on CC field is buggy

RESOLVED WORKSFORME

Status

()

RESOLVED WORKSFORME
13 years ago
8 years ago

People

(Reporter: jdanner, Unassigned)

Tracking

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; SV1; .NET CLR 1.1.4322)
Build Identifier: IE 6.0, Bugzilla v 2.20+

First, log into your own 2.20+ instance of Bugzilla.

Next, under Advanced Searching Using Boolen Charts, select
"CC" "contains the string" "depman1",
unselect all statuses,
and click Search.  Notice that 300+ rows are returned.

Next, under Advanced Searching Using Boolen Charts, select
"CC" "contains the string" "samir_bugzilla",
unselect all statuses,
and click Search.  Notice that 900+ rows are returned.

Now to demonstrate the bug: under Advanced Searching Using Boolen Charts, select
"CC" "contains the string" "samir_bugzilla" Or
"CC" "contains the string" "depman1",
unselect all statuses,
and click Search.  Notice that 0 rows are returned.

This is might be an ooooooold bug that has recently resurfaced into the latest Bugzilla.

Reproducible: Always

Steps to Reproduce:
See Details.

Actual Results:  
Notice that 0 rows are returned.

Expected Results:  
Should return at least 900+ rows!

Comment 1

13 years ago
I can reproduce the bug on tip. joel, is that a dupe and/or a known bug?
Status: UNCONFIRMED → NEW
Ever confirmed: true
OS: Windows XP → All
Hardware: PC → All
Version: unspecified → 2.20
Related to bug 422480? LpSolit notes that "the CC field uses a separate table in the DB".

Comment 3

10 years ago
We're also experiencing some strangeness wrt CC queries on the Mylyn project (http://eclipse.org/mylyn).  If you query within the Email and Numbering section for:

[X] a CC list member

doesn't match regexp

user@address.com

You get back a list that includes some bugs where user@address.com is on the cc list.

Additionally, if you try to append the CC doesn't match regexp to a query for
all assignees of a particular email address, the results exclude those reports where (the assignee is matched AND there are no people on the cc list).

Is this somehow the result of the assertion about CC field being in a separate table from comment#2?

Updated

10 years ago
Duplicate of this bug: 479948
This should be generally working on the trunk, now, thanks to a lot of fixes in this area.
Status: NEW → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.