Unable to search the message content (body) in encrypted (x509 certificate) mails

RESOLVED DUPLICATE of bug 188988

Status

MailNews Core
Search
RESOLVED DUPLICATE of bug 188988
12 years ago
7 years ago

People

(Reporter: Dieter Deppenaffe, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20060422 Debian/1.7.8-1sarge5
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.8) Gecko/20060422 Debian/1.7.8-1sarge5

If you want to search a string in encrypted x509 certificate mails, Mozilla seems to search the string in the messages without previously decrypting them. So Mozilla shows every mail which occasionaly contains the string as chipher text, but not the mails which contain the string in the decrypted form (aka. plaintext).


Reproducible: Always

Steps to Reproduce:
1. email acount which contains enctrypted mails
2. Tools->Search Messages.
3. Search for a string in the message body(s) (e.g. Body contains "world")


Actual Results:  
Mozilla will report some messages, but when you read them the String "world" will not be contained in thes messages as plain text.

Expected Results:  
Mozilla should only report these mails which contain the string (e.g. "world") in the plain text

Mozilla shows this behavior in serval Versions and Projects Thunderbird/Seamonky/Mozilla Suite  over the last years.

Comment 1

12 years ago
Similar to bug 132340.
Component: MailNews: Search → MailNews: Search
Product: Mozilla Application Suite → Core
Hardware: PC → All
Version: unspecified → Trunk

Comment 2

10 years ago
either a dupe or ...?
Assignee: mail → nobody
Whiteboard: dupeme
(Assignee)

Updated

10 years ago
Product: Core → MailNews Core
If the message is encrypted, the fact that we can now (on Trunk at least) search base64 content and look somewhat deeper in a multipart tree won't help us, since we would need to actually hook body search up to libmime to get the correct output parsing.

So this is still valid.
Status: UNCONFIRMED → NEW
Ever confirmed: true
Whiteboard: dupeme

Comment 4

9 years ago
This continues to be a serious problem in 2.0.23 for Thunderbird users who use encrypted mail.  It means that Edit Find SearchMessages does not work as specified. Nor does Thunderbird give any feedback.  [Body] [contains] simply reports no matches found.

Since this is assigned to nobody, will the behavior be the same in 3.0?

Comment 5

8 years ago
The behavior is the same in 3.0.

It's not fun using an e-mail reader that does not have the ability to search the body of messages.

Updated

7 years ago
Status: NEW → RESOLVED
Last Resolved: 7 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 188988
You need to log in before you can comment on or make changes to this bug.