Closed Bug 336672 Opened 15 years ago Closed 13 years ago

Print Preview - Headers do not display but will print

Categories

(Core :: Print Preview, defect)

x86
All
defect
Not set
normal

Tracking

()

RESOLVED DUPLICATE of bug 389358

People

(Reporter: edwardp, Unassigned)

References

()

Details

(Keywords: regression)

User-Agent:       Mozilla/5.0 (X11; U; Linux i586; en-US; rv:1.9a1) Gecko/20060502 SeaMonkey/1.5a
Build Identifier: Mozilla/5.0 (X11; U; Linux i586; en-US; rv:1.9a1) Gecko/20060502 SeaMonkey/1.5a

When the Print Preview window is opened, the headers are not displayed ar on the page that appears, but when the window is closed and the page is sent to the printer, the headers will print on the hardcopy.

The footers appear and print successfully.

This is not an issue with SeaMonkey 1.0.1.


Reproducible: Always

Steps to Reproduce:
1. Load in any web page.
2. Open Print Preview window, headers do not appear
3. Close Print Preview and print page, headers will print successfully

Actual Results:  
Headers in Print Preview window are not displayed.

Expected Results:  
The headers should have appeared when the Print Preview window is opened.
Problem still present in May 7 Linux nightly.

Mozilla/5.0 (X11; U; Linux i586; en-US; rv:1.9a1) Gecko/20060507 SeaMonkey/1.5a
This regressed between linux trunk builds 2006032909 and 2006033010, suggesting bug 331415.  But that was just a backend fix and FF doesn't seem to have this bug.
Assignee: general → printing
Status: UNCONFIRMED → NEW
Component: General → Print Preview
Ever confirmed: true
Keywords: regression
Product: Mozilla Application Suite → Core
QA Contact: general
Version: unspecified → Trunk
Corrected URL above to replace comma with period.
Changing OS to ALL, this bug is also present in the latest Windows XP nightly.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a1) Gecko/20060521 SeaMonkey/1.5a

OS: Linux → All
In the latest SeaMonkey trunk nightly, the problem doesn't seem to be that the header won't show in print preview. It does. The problem is that of the items you can choose to print in the header/footer, Title and URL will not display in print preview, regardless of where you place them --  header, footer, left, right, center. The other items -- Custom, Page #, Date, etc -- will display in print preview regardless of their location. All items do print successfully.

Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.9a4pre) Gecko/20070425 SeaMonkey/1.5a
I am currently trying out the latest Linux nightly of SeaMonkey 2,0 (2007090701) and this problem is still present.

The headers are not displayed in Print Preview, they will continue to print - although chopped off at the left and right sides of the paper, but the footers are displayed in Print Preview, but do not print at all.  I've also noticed that any print-related settings that I changed, only hold for the current session.  When SeaMonkey is opened afterwards, all of the print-related settings went back to the original defaults (cm instead of inches in the Page Setup window, and print margins (Print/Properties at .04 all around).

And if the Getting Involved with SeaMonkey page is printed (http://www.mozilla.org/projects/seamonkey/start/), neither the headers nor footers will print (they are also not displayed in Print Preview), the printed pages are chopped off all around.

I also reported a more recent printing-related problem, bug 391027.
Mozilla/5.0 (X11; U; Linux i586; en-US; rv:1.9a8pre) Gecko/2007090804 Minefield/3.0a8pre

Problem also present in latest Firefox nightly.
The problem appears to have changed.  With this nightly:

Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b2pre) Gecko/2007112002 SeaMonkey/2.0a1pre

Headers and footers are now NOT displayed in Print Preview, nor will they print, despite the settings in Page Setup which defaulted to millimeters, not inches.

Printed pages are not chopped off, but are not centered on the page.  This may have something to do with the header/footers not displaying or printing.
Please see https://bugzilla.mozilla.org/show_bug.cgi?id=389949#c15 (reopened).

Footers are now displayed, headers will not (after on the second and subsequent launches).

Mozilla/5.0 (X11; U; Linux i586; en-US; rv:1.9b2pre) Gecko/2007112602
SeaMonkey/2.0a1pre
In response to comment 5, in the latest trunk nightly:

Mozilla/5.0 (X11; U; Linux i586; en-US; rv:1.9b2pre) Gecko/2007112802 SeaMonkey/2.0a1pre

I do not see the headers in Print Preview mode, despite the settings on Page Setup indicating they should be there, but the headers will print.  
Mozilla/5.0 (X11; U; Linux i586; en-US; rv:1.9b2pre) Gecko/2007112602
SeaMonkey/2.0a1pre

See https://bugzilla.mozilla.org/show_bug.cgi?id=389949#c17 for a clarification on the appearance of the header only once in Print Preview.
Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9b3pre) Gecko/2008011402 SeaMonkey/2.0a1pre

In trying out the latest nightly, headers are still not displayed in Print Preview, but they will successfully print along with the footers.
Flags: blocking1.9?
Not sure this is severe enough to block
Flags: wanted1.9+
Flags: blocking1.9?
Flags: blocking1.9-
duping to a newer bug with blocking+ status
Status: NEW → RESOLVED
Closed: 13 years ago
Resolution: --- → DUPLICATE
Duplicate of bug: 389358
You need to log in before you can comment on or make changes to this bug.