Autocomplete options display when textbox is not even visible

RESOLVED DUPLICATE of bug 320938

Status

()

Firefox
Address Bar
RESOLVED DUPLICATE of bug 320938
12 years ago
12 years ago

People

(Reporter: bugzilla.mozilla.org, Unassigned)

Tracking

Firefox Tracking Flags

(Not tracked)

Details

(URL)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.0.3) Gecko/20060426 Firefox/1.5.0.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.0; en-US; rv:1.8.0.3) Gecko/20060426 Firefox/1.5.0.3

If a textbox has focus and the page is scrolled so that the textbox is no longer visible, the textbox will still respond to autocompete key sequences and display the autocomplete options on top of everything else.

Reproducible: Always

Steps to Reproduce:
1. Make sure you have autocomplete enabled.
2. Go to http://allelectronics.com/
3. Search for something (LED for example)
4. On the results page, click inside the search textbox so that is has focus.
5. Move the mouse outside of the textbox and use the scroll wheel to scroll down the page so that the textbox is no longer visible inside the viewport.
6. Press PageUp, PageDown, Up Arrow, or Down Arrow
Actual Results:  
The list of choices for autocomplete appear outside of the viewport

Expected Results:  
The page should be scrolled to force the textbox to be visible. If the Left Arrow or Right Arrow are pressed in step 6, the page does scroll as expected.

The bug also occurs with Firefox 1.5.0.3 on Windows XP SP2.
This may possibly be related to bug 216434.
This was fixed by bug 320938.

*** This bug has been marked as a duplicate of 320938 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 12 years ago
Resolution: --- → DUPLICATE
You need to log in before you can comment on or make changes to this bug.