Print preview in ver. 1.5.0.3 displays and prints Javascript instructions as text.

RESOLVED WORKSFORME

Status

()

Core
Print Preview
--
major
RESOLVED WORKSFORME
12 years ago
8 years ago

People

(Reporter: Arnold L. Bloom, Unassigned)

Tracking

1.8 Branch
x86
Windows XP
Points:
---

Firefox Tracking Flags

(Not tracked)

Details

(URL)

Attachments

(1 attachment)

(Reporter)

Description

12 years ago
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.3) Gecko/20060426 Firefox/1.5.0.3
Build Identifier: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.8.0.3) Gecko/20060426 Firefox/1.5.0.3

Print preview in ver. 1.5.0.3 displays and prints Javascript instructions as text along with the material that is supposed to be printed.
(I checked that Javascript was enabled in the Javascript console.)
The direct "Print" instruction in the File menu does not have this problem.
Firefox versions 1.0.7 and earlier did not have this problem.


Reproducible: Always

Steps to Reproduce:
1.Log on to a website such as http://www.sciencemag.org/ 
2.Drop down the "File" menu and click "Print Preview".
3.See the extraneous material displayed along with the web page preview.
4.Click Print. The printed page will also show the unwanted text.

Actual Results:  
Garbage is added to the displayed and printed web page.

Expected Results:  
Just print the Web page.

Major problem because I use the print preview feature to resize the material for printing.  This cannot be done by the direct print command.
Assignee: nobody → printing
Component: General → Print Preview
Product: Firefox → Core
QA Contact: general
Version: unspecified → 1.8 Branch

Comment 1

12 years ago
*** Bug 338520 has been marked as a duplicate of this bug. ***

Comment 2

12 years ago
Created attachment 236558 [details]
snippet of code from web page, modified by me (hopefully ok)

Using Fx 1.5.0.6 in SAFE mode to negate any effects from an extension:
Open this file in Fx, and then choose File/Print/OK.
Compare to print-out using File/Print Preview/Print/OK

With the Print Preview method, some of the javascript code prints-out too.
Assignee: printing → nobody
QA Contact: printing

Comment 3

8 years ago
WFM Mozilla/5.0 (Windows; U; Windows NT 6.0; en-US; rv:1.9.3a5pre) Gecko/20100518 Minefield/3.7a5pre
Status: UNCONFIRMED → RESOLVED
Last Resolved: 8 years ago
Resolution: --- → WORKSFORME
You need to log in before you can comment on or make changes to this bug.