Week number calculation doesn't respect the "First Day Of The Week" setting

VERIFIED DUPLICATE of bug 333372

Status

VERIFIED DUPLICATE of bug 333372
13 years ago
13 years ago

People

(Reporter: bugzilla.i.sekler, Unassigned)

Tracking

Details

(Reporter)

Description

13 years ago
User-Agent:       Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.8.0.4) Gecko/20060504 Firefox/1.5.0.4
Build Identifier: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.9a1) Gecko/20060507 Mozilla Sunbird/0.3a2

Select a Sunday in the minimonth or using "Choose Date" dialog: if the "First Day Of The Week" is something else, f.e. Monday, the displayed week number is wrong (+1).

Reproducible: Always

Steps to Reproduce:
1. Switch to the Week or the Multiweek view
2. Set the "First Day Of The Week" to Monday
3. Choose Date -> 07.04.2006 (April 7.)

Actual Results:  
The displayed week number is 19, that is wrong.

Expected Results:  
The displayed week number should be 18.
The patch in Bug 326270 will fix this issue.

*** This bug has been marked as a duplicate of 333372 ***
Status: UNCONFIRMED → RESOLVED
Last Resolved: 13 years ago
Resolution: --- → DUPLICATE

Updated

13 years ago
Status: RESOLVED → VERIFIED
You need to log in before you can comment on or make changes to this bug.